OS 1.14 - Incoming MIDI start message bug when record is armed

I have Reason sending MIDI messages, transport, and clock sync to the Hapax.

This was working fine, until all of a sudden I started getting an incorrect Hapax Clock Source warning that flickers on and off.

This only happens when record is armed via the Hapax. Which was working fine before. Restarting the unit did not fix it.

However, without record armed, the Hapax does not respond to any incoming transport play messages.

Here’s a link to a video of the behaviour: https://1drv.ms/v/s!AmYmXasihppxmY0YR9Db6DwVXYUj3A?e=FwC98J

(please not that all of the Hapax’s clock+transport OUT and THRU settings are disabled. This cannot be due to duplicate messages or anything)

Also, with transport stopped from both my computer and the Hapax, I pressed the “step” button. This triggered a few quick notes of playback on my computer, almost as if transport started for just a split second.

Edit 2: Reinstalling the firmware worked until I tried arming the record button. However, I am now able to receive MIDI start messages if record is not armed.

Thanks, this issue will be fixed in a new firmware, soon to come!