Odd length limitations of the Pyramid


#1

Been using this for about a year now. Two major limitations stand out, and have gotten in the way of my songwriting:

Note length is automatically quantized. What if I want a note to be on for 21/64ths? Or even 3/8ths? Can’t be done. In most other sequencers note duration can be any number of midi clock ticks at 96ppq. The Pyramid is capable of displaying this resolution, so why are note lengths limited to whole numbers of beats? I wish I could do something like hold down 2ND when changing note length and switch to ppq.

Sequences cannot be odd lengths. I have a song where a musical phrase is half a bar in 6:4 signature, equal to 12 steps. I can set the track length for all active tracks so that they play correctly. But for some reason when the sequence plays it repeats the phrase over and over, taking into account the time signatures of the inactive tracks, until they come back into alignment. The active tracks sync perfectly, but the Pyramid acts like they are trying to sync to the inactive tracks (which are completely unused/uninitialized). I can’t play through this sequence correctly and then sync back to the other sequences which contain tracks 1 bar in length. Am I missing something?

If anyone has any insight into these issues I would much appreciate it! I like to write songs with odd length phrases and I bought the Pyramid specifically because I thought it would be a good tool to accomplish this. Any help is much appreciated!


#2

“Note length is automatically quantized.” - not in live mode, as far as I know. In step mode, note length is a function of the zoom / time signature, so it is “quantized” in a way. But try setting zoom to 1600% and see how this affects changing the note length. Maybe tweak time signature and zoom settings at the same time, because both factors will determine the grid and note characteristics on this grid.

“Sequences cannot be odd lengths” - the length of a sequence cannot be set, it is determined by the length of the tracks/patterns involved plus various settings. I am very surprised that you cannot achieve what you want. Try adjusting the polymetry (polyrhythmic versus polymetric) setting and then especially the track run modes (free, relatch, trig) for each track.

Personally, I don’t understand why signature and zoom settings determine note parameters. This is unnecessary and confusing. In a way, it is some kind of “snap” function. Users should be given the option to disable/enable this behaviour.