Missing notes… timing problems

Hello,

I just recently purchased a Pyramid mk3. Coming from the RS7000. I have a studio with ~12 different hardware synths that I’m attempted to control with the Pyramid. When I have 2 or 3 different synths playing in the same midi port, I’ve noticed that I can program a set of 16th note hi-hats on my TR-707 and once they’re all on and playing the timing gets very funky and obviously not in sync. Whats weirder is that random 16th notes will just skip. No idea what’s going on here, but it’s made the Pyramid nearly completely unusable to me. And before people mention midi limitations, I’ve been using my RS7000 to control all of my synths without any similar issues. The RS also has only 2 midi out ports, so it was a simple switch from it to the Pyramid. The Pyramid just doesn’t seem to be able to keep up with the data. I’ve only been testing with notes. No FX or CC automation. Also tried turning midi clock off on both ports which hasn’t helped. Pyramid is using v4.02.

Am I missing something? Some hidden setting that needs to be switched on or off? Is my Pyramid not functioning correctly? Is the processor on the Pyramid just not fast enough?

Any help is appreciated! Thank you!

Quantizer is on by default at 16th notes.
Check Fx and turn them off if it helps

Doesn’t help, unfortunately.

Check the midi inputs/outputs monitoring now (2nd+fx, 5th screen).
Turn off multimode midi, turn off midi in. // simply reset Pyramid//

If it’s still happening, turn off all synths and go one by one….

How is the midi routed from pyramid to the synths?

The routing is exactly the same as on my RS7000. Port B to Kenton Thru 5 to the TR-707. In fact, if I unplug everything and just plug in the TR-707 to Port B on the Pyramid, with no other synths plugged in, I still get the missing notes and timing issues. I tried recreating the exact same patterns on my RS7000 with no issues. So it has something to do with the Pyramid, just not sure what.

I’m not sure what multimidi is, but looked through the settings and everything suspicious has been turned off. Also tried hard reset of the Pyramid and the issue persists.

Getting there:

Try the monitoring now. Midi in, midi out (turn off clock in, clock out for the test)

Do you see any issue , what you see? Midi echo off or on, in case midi in is allowed

Kenton is good.
The power supply to pyramid is via USB or the origo PS?

I still can’t figure this out. I can’t tell if it’s an issue with the tr-707 or what. I tried 3 different tracks. One, the 707, the other two just on the same midi out A on different channels. I have all 3 tracks playing 16th notes. If I slow the whole thing down to < 40 BPM the 707 will play notes. If it goes above 40 BPM it just completely misses the notes with 3 tracks playing. I watched the midi page and everything looks fine.

I can’t replicate this on the RS7000. No idea what is going on. I also tried different note lengths but that doesn’t help either.

Update:

I used an Arduino and wrote a program that filters out all midi channels except the ones that are being sent to the TR-707. This added some latency, but I’m no longer getting missing notes or timing issues. So the issue is the TR-707, but it for whatever reason is not an issue on the RS7000. The TR-707 just doesn’t like how midi data is being sent from the Pyramid.

I ordered a Midi Solutions Router for a permanent and possibly faster solution to the problem. I guess this basically fixes my issue, but still I’m unsure why this would be happening. Regardless, I have a working solution and it seems I will still be able to use the Pyramid which is great, because I’m really enjoying it.

Thanks for the help. Hope this thread can help others in the future.

Sunshine Jones had some recent posts about troubleshooting MIDI sync problems with several of his Roland x0x boxes – basically he had to put together a custom cable that accounted for differences in the way different units handled the DIN sync signals between Pyramid/Hapax and the drum machines. might be along the same lines as your issues

interesting. i’m not sure how i would find those posts. searching didn’t bring anything up.