"Missing Instrdef: 8.9.15" on project load?

Hey! I’ve recently updated to the most recent 2.x firmware from 1.x. I also decided to re-organize which external synths/devices were on which of the 4 Hapax Midi Outs. I’ve created custom Instrument Definitions for my hardware synths, and created a Template, assigning certain Instrument Definitions onto the various Hapax tracks.

Everything seems to work, particularly for the limited few synths I have plugged into the Hapax at the moment.

But every time I load the Template (or a new Project I made based off the template), I get an error that splashes up for a couple of seconds that reads:

“Missing Instrdef: 8.9.15”

I’ve tried look at each of the instrument definitions associated with tracks 8, 9, and 15, more closely, and don’t see any issues. But I’m not even sure if the error message is telling me that there are missing definitions associated with three tracks, or if it’s saying there’s an error specifically in instrument definition 8, and then 9 and 15 maybe mean row numbers or something?

That all said, the tracks associated with the Instuments on tracks 8, 9, and 15 all play, and even if I reload the instrument definitions associated with those tracks, and then re-save the Template or other project file, I still get that same “Missing” error.

Any ideas on where I should look to solve this?

I can confirm that the error is tracks 8, 9, and 15 each have an instrument definition file which was not found.

That can sometimes be caused by long file names and/or special characters in the name of the file. Are the file names somehow special ?

1 Like