MIDI input problem since PyraOS 2.10 or 2.20

Hey there,

unfortunately i experience a serious problem since updating i think either to OS 2.10 or 2.20.

Simple task:
use the keyboard of my analog synth to record or simply play midi into (or through) pyramid.

pyramid only receives cc messages, but no notes!

I know that there are many possibilities that this is my own fault, but i have checked everything from midi settings in the synth, settings in the pyramid, cable etc. (several times)

Especially the fact that everything worked fine before updating to a new pyra OS version speaks for some kind of bug!?

I am not quite sure which version it was as i didn’t take notice of the problem right away after updating.

I was hoping this got fixed in OS 2.3, but it is still present.

Please help!!!

First thing to do. Go into Settings -> Misc and scroll down until you get to the “MIDI Input” page. No try sending notes from the controller and see what is displayed. This is the raw MIDI data coming into the Pyramid. What do you see there?

you mean settings -> info ? …. there is no “midi input” in the Misc-settings

on the “MIDI IN” page (INFO) i see nothing when sending notes (or Controller data)

Can you connect your controller to a computer or any other device to verify it is in fact sending MIDI?

yes, i tried and it is sending midi.
i was assuming it is because when in step or live mode the triangle flashes when turning a knob on the synth… but not when pressing a key

It sounds like notes are being filtered out. Depending on which brand it is, some have a button to turn keyboard off, (I had that on my PCR300).
If CCs are coming in everything is ok…as @joosep said it’s something in settings somewhere.

yeah, i know. Its in the local control settings.
As i said, i checked the settings on both machines more than once.
And it was working fine until Version 2.xx
I just once more tried sending notes to another midi-device and it is receiving the notes!

You can restore all default settings at startup: hold FX while powering ON Pyramid.

If still nothing, then you can roll back your Pyramid an older OS. Works exactly the same as upgrading.

Okay…thanks. So where can i download the PyraOS V2.00 file?

Try this: http://squarp.net/05_pic_pyraos/2000/PyraOs.bin

thank you! Now it works (again) :wink:

Great news!

Now what happens if you download the latest and update to that? :wink:

Then it is not working…

I just realized i had V2.10 active, because i already “downgraded” for testing purposes some weeks ago.

So i upgraded to 2.3 again first, to make sure the problem occurs with the newest version.

But now we know, 2.0 works, 2.1 and up does not :wink:

Or do you think i should try the upgrade once more?

I think this where my level ends. You should collect all your findings and email it directly to Squarp!