MIDI Definition File Filter Doesn't Seem To Work

Hi, just looking for some clarification. Perhaps my expectation for how this works is a little off, but the manual claims that if you turn on MIDI CC filtering in the settings it will only show CC #s that have actual functions in your definitions file. But I’m seeing huge lists of empty slots and there’s a lot of scrolling between the empty gaps between functional CCs and empty slots. I thought this was meant to remedy this issue?

From the manual:

● If an instrument’s CC number is not defined in the .txt file, Pyramid will not display it in the CC messages list, allowing you to filter unused CC messages (only if SETTINGS > MISC > LOAD DEFINITION = FILTER CC).

Just an addition also: This Definition File info isn’t loading into the slot I “CALL” it into: Not sure why. I assume it’s me, but I’m confused why some work and some don’t.


If I may restate what you’re asking so I have clarity:

When you use a Definition File, and you have your Settings to Filter CC, and you are using the correct Channel and Port for the destination in question, the CC’s available while scrolling on the Pyramid are not filtered as you would expect them to be.

Is this what you’re asking?

This is exactly how it works for me.

For example, I have a Definition file for the Rample which filters out all CC’s that I don’t use. If I want to use the Step Editor to throw some chewy Freeze FX in there, I just hold [Step] and rotate the Main Encoder to get to CC’s, then release Step and as I scroll the Main Encoder I only get the CC’s for which I’ve defined in the Definition File.

A few things to check:

  • Have you set the Track in question to Output Port B and Channel 3 before selecting a CC?
  • Are you using the latest firmware?
  • I’m assuming you’ve verified the settings in Misc to filter.
  • How many Definition Files do you have? Or more specifically, how many Definitions do you have? (as in, if you have 4 Definitions in 1 file that would count as Four)
  • Does this happen on a brand new Project?
  • One suggestion, not that I’ve heard it’s an issue, is perhaps put your CC’s in order? Also, the Pyramid only sends out up to CC119, so anything above that should be ignored, but I’d remove it just in case (and document if this is the ‘fix’ and send that info to Squarp).
  • You mention [quote=“deep_transmissions, post:1, topic:5368”]some work and some don’t[/quote], so I’m wondering if there are any similarities between the ones that “don’t work”.

Yep, everything is set according to your notes / questions.

Although to save my slots (I know there’s a max you can have in the file) I’m reusing this definition as on my Jomox Alpha Base drum synth, there’s really 4 definitions for 11 instruments. Each is triggered by it’s own midi channel, but onl7 4 are actually unique when it comes to Control Change, so I manually load using the CALL function this particular set of definitions over the 8 channels that are the same, and then update the MIDI channel manually, so you asked if this was channel three, it;s actually not, it;s channel 9, but in this case after calling the definition I am updating the midi channel and that works fine.

I don’t see any of these for my instrument, and not only should they autoload when I start up the pyramid but I’m also using the CALL feature to manually add it, and it’s just not working, some instruments it works, others it doesn’t.

I’ll do some more digging and testing.

I have troubles with definition file and file filter.

First some of the files I found on the forum, were not clean. I think there was a problem with the encoding, and there was a lot of white spaces. So I created a new file with a good text editor (vim), I copied the content of the file downloaded from the forum into my new file, and there I deleted all the white spaces.

But now I have cleaned my files, I respect all the things CreepyPants propose to check (and the CCs are in order), and still the control change does not get filtered.

1 Like

Did cleaning up your .txt file result in any improvements?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.