Midi controller muting and unmuting tracks while performing

Hi, i recently got a Pyramid and love it.

I need a little help.

I am controlling the Pyramid via a midi keyboard so i can perform and record live. That works well. however, certain keys mute and unmute tracks while performing. It makes it impossible to play as drums get unmuted by accident etc.

I’m sure its something simple but i cannot find a way to stop the keyboard controlling the mute states.
I have been through the manual and this forum but to no avail.

Does anybody know how to fix this?


Check your midi in setting. You shouldn’t use the same channel both for control pyramid and play notes.

Disabling the midi in works, but when i do that, the controller or pyramid seems to double fire midi.
For example, i record a pass using the keyboard it sounds fine during the performance, but when it loops and plays back, notes are choking .

I have midi echo on (if this is relevant)

1 Like

Are you using PyraMIDI to mute/unmute tracks?

Not as far as i know. Not sure what PyraMIDI is? I don’t want to control the mutes from an external controller at all if that can be disabled?

I’d go to setting/info/midi in <> midi out. Check what is happening in/out

Btw, it is important to save setting before you turn off pyramid while experimenting. Have a factory reset, start again and use blank projects A B C etc. to save there your settings.

Verify in your Settings that PyraMIDI is not on.

The behaviour you are describing sounds like MIDI Note Events are Muting/Unmuting whichbis a function of PyraMIDI

Pyramidi is on. But when i disable it, i get the problem of the midi double firing/choking notes.

Previously this is what i was referring to when i disabled midi in, i didn’t know it was called pyramidi

i will give this a go too. I have just got everything up and running today so will work around the problem for now and try this over weekend. Thanks

(the factory reset)

One of the functions of PyraMIDI is that incoming Note Events Mute/Unmute Tracks.

You have a problem with Note Events Muting/Unmuting Tracks, which you dont want.

PyraMIDI is not the same as MIDI In.

Double notes/chokes sounds possibly like you have synth with Local On and routing the MIDI out of the synth, thru the Pyramid, and back to the synth, but more info would be needed to troubleshoot that. (Separate issue)

Could you please look over my setup below and let me know what you think?

I am using a rev 2 as the controller with local off into the Pyramid.
From the Pyramid i am going out midi a in to a thru splitter box to various hardware instruments, one of them being the rev 2

I am using the rev 2 in multi mode stack, so i can utilise both layers on separate tracks in the pyramid
(local off)

With pyramidi off, the choking happens when i play any instrument from the rev 2 through the Pyramid. Through trial and error, the only way i could get it to work was to turn on Pyramidi.

Maybe it cant be done?

Choking and pyramidi are unrelated.
I’d turn pyramidi off… as it’ll just confuse things. (and will stop your muting issues)

from there, you can use the midi monitor on the pyramid (settings-> info → midi in/ out) to see what messages are going in and out, and so look for anything ‘unexpected’.

(turn midi clock OFF whilst doing this as otherwise thats all you’ll see in the monitor :wink: )

most likely your issue is something echo the midi back to the pyramid…
hopefully you can determine this from the monitor
another approach is start unplugging anything that could potentially be looping back midi to the pyramid.

thats a handy tip turning the clock off!

So one press of a key is firing twice (on and off x 2). i think thats because the rev 2 is sending out midi on 2 channels.
So i set the omni mode to receive from just one of these channels, that has stopped the double firing but now the rev to seems to be getting triggered as i hear it when playing on a drum track for example.

Is that the right use for omni? i’d like to just tell the Pyramid to take midi from channel x

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.