Metronome velocity different on MIDI A vs MIDI B

Hello, I’m new to the Pyramid and returning to synthesizers after a bit of a break, but been playing off and on since the mid 80s.

Trying to setup the Pyramid to play the metronome sound on an Alesis SR18, semi-open hi-hat for now.

I got it working if the SR18 is connected to MIDI A. But if connected to MIDI B and changing the metronome channel I can’t hear anything. The monitor is showing the appropriate note at velocity 127 on the first beat and 64 on subsequent beats. If I switch the SR18 for a synth and test the two MIDI ports/metronome channels the metronome is much louder on MIDI A than it is on MIDI B with no other changes than swapping the output port and changing the metronome channel.

So while the MIDI monitor is showing the same velocities out when using A or B, it appears I’m receiving a much lower velocity when using MIDI B for the metronome.

Is there some kind of velocity setting within the Pyramid that I’m missing? PyraOS is 3.23.

Thank you.

very odd…

there should be no difference sending on DIN A or B.
and the midi monitor (info screen) should be saying what’s being sent out…
Id be very surprised if this is ‘misleading’ you.

does the same happen if you send notes from a normal track out of DIN A/B?
also with different sounds on the SR18? (to eliminate possibly of some kind of choking behaviour on hat)

just wondering if this can be tied as as specific problem to the metronome or its all note output.
similarly if its something ‘interesting’ going on with your hi-hat, and timing?

seems like a really odd thing for velocities to be different… or how/why that would happen.
unfortunately, its hard to say what to try
what I would personally do is use an external midi monitor, to look at the midi.
e.g. if you have a midi din to use cable, you could route it to your computer to check.

unfortunately thats the only way I can think of for confirm velocities are different, rather than some other obscurity… which is what Id want to confirm as a first step.

note: Id also update to the latest firmware, im not aware of an issue it’ll fix, but generally its a good idea… esp. when seeing bugs that you might need to report.
(last change to metronome code, according to change logs, was around 3.0, but who knows !)

once you have updated to latest firmware, and can reproduce… then you can contact Squarp via the contact form and they can see if they can reproduce.

try with an external monitor

my guess is you got a midi loop on A which makes it sound twice => louder

Thank you both for the suggestions. Going to try recording/playback on B to see if it exhibits the same behavior. Then an external MIDI monitor - will need to get an interface for my computer. Probably won’t have a chance until this weekend, but will report back.

just remove the input, see if it still happens

if yes, connect out A to IN (make sure midi thru is off) => monitor the input on pyramid instead of the output
after that do the same for out B.

Well that’s just a little too obvious, thanks rv0. The monitor on MIDI in is showing velocity 127 from both A and B. So clearly some other setting is off. That’s reassuring and now I have some other troubleshooting to do. Should have some time this weekend.