Main encoder issue - 2nd time

Has anyone had an issue with the main encoder?

I bought a pyramid from a dealer in the US, received it, and then the encoder stopped working after about 30 minutes. I would try to change the channel or the length on a track and you see on the screen it’s going through the channels or adding bars but then it will stop…the knob is still turning, just the channel or bars will stop randomly. I tried to turn the knob slower, faster, try and click and unclick and turn it again…etc. After around 30 minutes, it then would not change any parameter on any screen…like it got disconnected from the electronics. I retuned that unit.

I JUST received another one directly from Squarp and OMG, same thing. Turing the track channel to a Midi B and it only goes up to Midi A 12 or Midi A 14. Then, will go down and then up again further or less… Tried to lengthen the track…again, stopped at 7 or 8 bars…then magically after turning it left and right and slower and faster, it got up to 13 bars but then would not go any further.

So frustrating…I sold my MPC One and my Octatrack to get one of these … I had one before 2 years ago that worked perfect. Now, I cant work on my music yet again.

Just checking if others have had main encoder issues like this…I just want one that works!!!


Wow. UGH indeed!
I don’t know how you keep your cool - I’d be posting with caps and expletives after the first episode, but I’m extremely cranky and don’t play well with others.
Congrats on keeping some calm (but I know that doesn’t actually resolve anything)

I’ve had my Pyramid for a few years now (I think - I forget) and I’m not terribly gentle with my hardware, but I’ve never had encoder issues like this. Mine is a MkII tho.

Hate to suggest a route you’ve already been, but best bet would be to contact Squarp at

If anything they should be tracking these hardware issues and hopefully find the source of the build problems maybe…? I don’t know.

I thought I read somewhere that there was a batch of units with some kind of encoder issues but not sure if it was the main encoder or not.

Have a Hypersynth Xenophone and a Behringer Pro 1 coming tomorrow and was hoping to have some fun with them…still can of course…but not the fun I was hoping for.

My wife is furious and she is not even into music making…she keeps telling me to call and complain and demand so and so…I’m the calm one in the family so I sent a fairly long email to them. But, if things dont get resoved at least I got the pitbull wife to unleash!


very weird unlucky, as you can see from the forum - lots of users have pyramid that behaviour properly,
so not this is an unfortunate event.

also not seen a rise in faulty reports here… nor reports of a ‘bad batch’.

as @CreepyPants said, really only course of action is
a) return to dealer
b) contact squarp,

good luck , hope you can get it sorted out swiftly.