Logic Pro recording count in problem

hi everyone , when i work in Ableton Live , i’m able to set a recording count in and the squarp will start after the count in , perfect ! . But when i try the same with Logic pro , the squarp starts at the count in , which pretty annoying to record .
Anyone an same experience or a solution ?
thanks a lot

First thing Id check is when Logic is sending the FA MIDI Sequencer Start msg. Ableton is working as expected sending it after countdown, but logic sends it at start of countdown.

Id check for a setting in Logic first.
If there’s no option, the only solutions that come to mind for me involve translators because i have a hammer and everything looks like a nail. :wink:

i checked every option in logic and couldn’t find anything .

What MIDI clock mode/start location in Logic do you have selected for Pyramid?
According to a quick Googling (and completely unaware of what version you are using):

“After you set the MIDI Clock mode, you can choose where in your Logic song you want MIDI clock output to start.”

(In “MIDI Sync Settings”)

That sounds like a lead I’d follow.
Your mileage may vary.
Good luck!

i have the logic 9 version so i don’t think you can choose the mode for the syncing . I have two destinations , one is sending clock to the squarp and one to the beatstep pro .

i have the feeling it behaves the same no matter what gear is connected . A old roland r8 , a beatstep pro or a squarp

In my understanding, the Pyramid starts when it receives the MIDI Start Sequencer message (FA) followed by a MIDI Clock message (F8).

So, irrespective of your routing, I’m under the impression youd need to ensure whatever software youre using is sending the correct info to yield the results you desire.

if i understand you good , i think you’re speaking about the options you have in logic X to choose your clock to behave as pattern or song and some other options ?
there must be a way to do it in logic 9 ?

hey - I slave the pyramid to Logic when recording. I noticed that there can be an issue between when the PLAY is sent to the Squarp versus a latency in logic for recording. So if you’ve got a count in, things still kinda record weird and stuff will happen like you’ll miss the start of the recording.

I dug around for a bit, and while there isn’t a solution that’s super intuitive, I did find solutions. How to fix this is you need to adjust when Logic sends the PLAY to the Squarp, then you can fiddle around with count in or pad a couple of bars or whatever you want. What I do is I have the PLAY sent AFTER the recording starts. Something like, I hit the record button, then logic counts like a bar (recording dead air) and then starts recording. That, at the very least solves any audio cut off problems.

Anyways, I’m not entirely sure this will solve your specific problem and I’m not sure what your workflow is - but that’s helped me sync logic and the pyramid for recording purposes.

Btw, I’m not near my studio right now so i’ll check this later. But I think it’s in here:


Note there’s a ‘START POSITION’. I’m 80% certain that’s where you change the setting. You set the start position to say BAR 2 and start recording at BAR 1. Anyways, if this is inline with your problems I can check how I do it when I get to my studio, let me know.

hi thanks for your reply , like i mentionned i’m working with logic 9 , i have no issue syncronising them , it’s just that when i choose a count in to do a punch in recording (for ex between bar 32 and 37 , the squarp will start its sequence when the count in begin (for ex one bar before 32. i do not have this problem with ableton live 9 without doing any particular setting .

yea - i mean logic 9 was old several years ago. You should really consider X, they’ve put a lot into it and it’s vastly cheaper than live (200 bucks last i checked with free updates). Note that I also have both LIVE and Logic, so i’m well versed. And maybe live is a better setup for you - though I personally prefer to do my recording in logic.

Anyways, in 9 you probably can still mess with what I’m talking about. The issue right is that at the count in the PLAY it sent to the squarp. So if you know where the punch in is going to be, you can go to that setting I told you about and fudge the PLAY start to whatever Bar you want to punch in at.

Btw, personally, I find punching in with the sequencer to be a chore. I just don’t do it. Instead I play things as right as I can, and if there’s a little bar or two that’s messed up, I’ll usually fix it in edit. Like, I’ll record the two bars on some extra track, then I’ll cut out the bad stuff and cross fade the new recording in. So it’s like the long way around punching in. But ya, I’ve just found it to be too cumbersome to work that way with the sequencer (note the case for live musicians, of course)

oh and I just thought of this - but you could probably also add a padding bar on the squarp. Like give it a bar with 4 counts before it plays anything. That kinda sucks, but it might work.