Live Recording Notes Early in Hapax Grid When Receiving Clock from Ableton (Part 2) please help [watch video]

I made a thread about this previously, and we made some good progress, but after another month in a half, I can say this is the single largest issue I face with this device, and I am struggling to wrap my mind around it. After that thread, I chalked it up to my setup and timing, but after spending more time with it, I have a really hard time accepting that. Please watch the video first here. It might help you follow the thread.

Here are some configuration details:

  1. Ableton is set as master.
  2. Hapax synced via cv Ableton device. The sync is solid as tested below.
  3. To test clock and latency, I send CV sync start and midi notes to hapax. The latency results in 6% difference in maximum note result. If I send a note that is 100% on grid in Ableton, it shows 6% off in hapax. This shows the sync/timing is pretty tight and this is not the problem. Note: None of the issues below are related to sending midi notes from Ableton to hapax, they are related to recording notes in hapax using hapax pads, while receiving sync in from Ableton. I only include this to show that clock sync between Ableton and hapax is pretty tight. For these tests of the actual issue below, there are ZERO notes going from Ableton to hapax.
  4. All notes are entered with hapax pads. I noticed this in both single note entry and chord note entry.
  5. There is no quantization.
  6. There is no midi going into the hapax from Ableton or any other source.
  7. I am not using direct monitoring; however, this has nothing to do with actual audio really and has to do with the timing of the pad presses, prior to audio even being generated.

To reproduce:

  1. Setup using the configuration above.
  2. Arm hapax for record.
  3. Start recording with Ableton using a count-in.
  4. After count-in, attempt to play hapax pads to record notes into the hapax sequencer.

The issue occurs nearly 100% of the time.

When receiving CV sync-in or usb midi clock-in from Ableton, hapax generally seems to be recording notes too early on the hapax sequencer grid when recording pad presses. It always seems that the pad presses are too early. There is an additional related bug where, when doing a fresh live recording synced to Ableton, the first pad press upon start of recording, will register as a lengthy note press midway through the loop and extend itself all the way until the end of the loop, instead of registering with the expected brief length at the start of the loop. This is documented in the video. As far as I understand, this should not be possible. Can the hapax technically record notes before it starts? If so, why is it recording notes mid-way through an 8-bar loop, where I clearly did not press it.

If you do not understand, watch the video, you can hear that I press the pad near the start of the recording (it is on a 4-beat count in and you can see it start, note that there is no audio, it is just the pad presses that you hear). Instead of the pad press registering at the start of the bar, it registers midway through the end of the 8-bar loop and extends all the way to the end of the 8-bar loop. That is impossible based on what I pressed.

Can someone give me any insight into why, after proving the timing that I have is relatively tight, that I would experience such a feeling of early input when trying to record pads? Also, the bug where when starting a live recording, it randomly puts the first note midway through a 4-bar loop? I would be partially willing to believe it was my fault and a timing issue, but my issue combined with the device seemingly showing that it is having trouble receiving pad presses when receiving clock from Ableton, really has me suspicious.

I could see this being argued as all attributed to clock latency but the clock latency as described in the configuration is very low and not really significant enough to cause this amount of discrepancy.

NOTE: If I record the audio in Ableton from the synth at the same time as I record the pad presses on the Hapax grid during the test, Ableton captures the audio at the start of the bar exactly as where I expect it and hear it as starting. So, the audio is good, and my timing is good, and the clock is solid, but the hapax grid recording is early and off.

early recording - YouTube

In the image above, the extremely long note is the early recorded note that occurs immediately upon initiating recording. For some reason, hapax thinks the first press was a long hold and midway through the loop (even though the recording just started).

NOTE: I decided to test this with hapax clock as internal, and I could not reproduce. All the 1st notes were strongly aligned at the start of the bar. And I am not even using a metronome. I just put the hapax to internal and 4 beat count-in and used my eyes. So, I really feel like there is an issue with hapax registering pad presses and recording pads when receiving CV sync clock (nvm it applies to midi usb clock as well - see note below) from Ableton. This further reinforces that my timing is decent enough.

NOTE: I decided to test this with USB midi clock in from ableton instead of the CV sync in. I got the same early recording results described in the issue. So it does not seem that this has to do with the CV sync configuration.

Note: link to original thread Live Recording Notes - Early? - Hapax - Squarp Forum. User @polynil also noted that they feel they experience something similar.

I’d highly recommend sending this to Squarp support. I have worked with them directly on a few issues and they’re really helpful and will try to fix the issue, or work out if it’s a firmware issue they can fix, and they’ll possibly get you to test with beta firmware updates whilst they work with it.

I did try this (albeit only with USB MIDI sync) and couldn’t replicate.

Out of interest, do you have anything like an external drum machine or groovebox you could clock from Ableton as well and send pre-sequenced MIDI notes into the Hapax? Be interesting if the behaviour is the same as this or different.

Honestly, though contact Squarp as they are wizards at tracking stuff down.

I appreciate your comment.

I am in contact with them. I did send midi to hapax from the PC. It seems completely on time.

I am using Reaper as my DAW, and you could download that (it’s 12MB and free to use for 30 days) and see if it’s an Ableton-specific thing perhaps?

oh that’s a good idea.

The other thing I just thought of, if you set the track you’re playing on Hapax to output to USB and send that to a recorded channel on Ableton, if you press the keys on Hapax, are the notes also recorded late on the Ableton track? (I am assuming they would be, but worth a test to see)

@Loz hmm. Great ideas. I have sent midi to the pc before from hapax, and it is nearly perfectly on time. This issue seems to revolve around pad presses and mainly at clock start, not during loop.

I am really starting to think that the major issue here is the “early and long” note record bug during initial start of recording that occurs in the video, and maybe not actually a timing issue. So, any early press of the pad when starting the recording causes maximum frustration. It is pretty hard to describe in text but obvious in the video, so sorry for the challenging explanation.

That bug is super frustrating because you cannot really easily fix it. You can of course edit the notes, but it kills the flow and the vibe if you have to do that each recording. That bug also makes it appear that the notes are recording extremely early, because the note begins randomly somewhere in the middle of the loop before its even started. Making me think it is registering a super early press, when really it is just a regular early press. But I am thinking maybe the actual placement of that buggy note has little to do with how early you press the pad and only matters that you press it early at all. It seems to be random as to where that note is placed in the middle of the loop.

So, maybe my frustration with that common bug has made me mentally convinced that the pads are recording too early. and then me trying to compensate to avoid that, has caused an overall mess of my pad timing.

Long story short, if the bug (assuming it is a bug) is fixed, I think it will resolve the “timing” issues. I have sent it off to the squarp team, so fingers crossed.

Yeah, can totally get why it’s frustrating. It’s not clear from the video, but are you starting the Hapax in Record mode? Is so, have you tried having the Hapax playing, then hitting record and starting playing from then? Is it late then?

One thing to consider: Ableton changes the way it records midi depending on the monitoring state of the track. When monitoring is off, it will record it as it is received. However, when monitoring is on/auto, it will apply latency, to compensate for the the fact that your brain will compensate for the latency and will play “early” so the audio is in time.

Long story short: For recording external sequencers, you should turn monitoring off. Midi notes will then be a little bit late, because of the inherent hardware latency, but it should be close to the grid.

If that is correct, then your Hapax is clocked correctly and I assume playing it live should also be in time.

The squarp team sent me a firmware that resolved this issue. feeling so good now about it. they made it so any early note is automatically aligned to 0 on the first 1/16th note of the loop. this makes my life soooo much better lol. no more of the random note midway through the loop (as shown in the video) causing complete chaos.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.