Live Mode - NO Metronom before recording

I can’t set the MIDI metronome countdown before recording starts. What could be wrong??


Two possible things.
Settings .> Misc -> Rec. Countdown -> 1Bar/2Bar …
Activates a countdown before a recording in live mode (When the player is stopped and you press REC then PLAY). You can select the duration of the countdown. The countdown will be sent on the metronome output channel and note.
This should not be OFF.

Settings .> Misc -> Metronome Ch -> MIDICH01A …
Select the metronome output channel (made with midi notes). If the metronome is activated (2ND+LIVE), the metronome will be send on this selected track, and will follow the beat.
This has to be set to the dedicated metronome channel.

I have set my “Metronome channel” to “Current Track” and “Rec. Countdown” to “1 BAR”.
(Also have the “Metronome note at E4”, but thats random).
So when I go to LIVE mode. Sequencer stopped. Press Rec to arm the record and then press play. I get a 1 BAR countdown with a audible metronome. The metronome in my case is E4 notes on the output channel of the active track.

Hope this helps :wink:

1 Like

Might be stating the obvious here but you are going to hear the metronome countdown playing blip, blip, blip, blip or clunk, clunk, clunk etc from the synth/module/sampler that’s connected to that track and MIDI channel.

So check that that synth’s audio output is connected AND that is it going to respond with a sound when it gets that E4 note. So like make sure if it’s a sampler or drum machine you’ve got a sample/drum assigned to e4 or if it it’s a synth check it’s in a playable range.


1 Like

Thank you very much for your help. It works also on my pyramid!!

Thanks for your Help. Now it works fine! Super!

1 Like

@joosep What’s a dedicated metronome channel? That might be where I’m going wrong…

The metronome works for me when it’s set to current track, but no other setting, even if I assign it to the track number of the current track. Ideally I’d like it on another track. Thanks!

What do you have for Settings -> Misc -> Metronome Ch and Metronome Note?

It doesn’t seem to matter what channel it’s set to, unless it’s Current Track, it doesn’t work. I’ve got it set to E4.

My plan was to record something on 1A and use the metronome on 5A. When I set it to current track and I’m on 1A, I get a metronome sound from my 1A instrument. When I set it to current track and I’m on 5A, I get a metronome sound from my 5A instrument.

When I set the metronome to either 1A or 5A, it doesn’t work.

What Port & Channel do you want the metronome data to be sent on?
Is the MIDI Device on Port A Channel 1 the same as the MIDI Device on Port A Channel 5?
That is a leading question: what device is it that you want to be playing the metronome?
And then: what channel is it listening to?
Does it respond to the Note# that you have set for the Metronome Note?


I think generally if you simplify the question this way:

  • Is the sending device sending the correct data?
  • Is the data path correct and free of errors or hardware issues?
  • Is the receiving device set to process the data as expected?

You can sort of verify part of the first bit by just turning on the Metronome while playing a Blank Project and then pressing [2nd]+[Live] to turn the Metronome ON if it wasn’t already on. Then look on the screen in the upper right hand corner to see if data is at least getting sent on beat as we’d expect a Metronome to play. If so, excellent.

The press [2nd]+[FX] and select [Info] and scroll down to the MIDI OUT Monitor to the Port you’ve designated for your Metronome Channel and verify that the Metronome Note is being sent as a regular Note Event.

If all of these things yield: true, then for practical purposes we can move forward assuming the Pyramid is doing what it needs to do, unless you have a MIDI Monitor software such as MIDIOx that you can verify the data.

As for the second of the troubleshooting checklist, that comes down to things like:

  • Are your cabless physically sound?
  • Is the correct Pyramid Port hooked up to the correct MIDI IN of your device
  • etc

For the third part, that’s characteristic of your specific device.
If you’d like to name it, I’m sure there’s a good chance someone here may be doing the same thing and may have some insights if the problem is there.

But again:

Well, this is embarrassing. I somehow got confused with Track and Bank # with Port and MIDI Channel #.

@CreepyPants - I really appreciate your patience and thorough response.

On to making some music with this fabulous machine!