LFO possible bug?

when i set a synced LFO (effects) with a certein phase, offset, etc and send it via CC

then deactivate it and activate it again

it is at the wrong position

after restart, the position is correct again

could you check/confirm?

1 Like

I talked to the support and they told me it should have been fixed with the latest updates. but it is still the same here,

could one of you check please?

send a LFO via cc to a synth, set the lfo : SYNC, set phase, offset,

then deactivate it and activate it again, then it is at another position.

i have to push stop and start, then it is ok again.

Do i miss something, like this is a known thing to you all?

Otherwise it seems a bid weird, that i’ve been asking for 7 days if one of you can confirm this and get no reaction at all. I mean it takes a few seconds to try it.

I’ve been meaning to reproduce this but never actually got around to it.

What do you mean by “wrong position”? What behaviour do you expect and what do you see instead?
Say this is the LFO

/˜\_/˜\_/˜\_/˜\_/˜\_/˜\

Now say you deactivate it for three partial cycles (o), maybe I’d expect it to keep running sort of in the background, just not sending CC:

/˜\_/˜\ooo\_/˜\_/˜\_/˜\

Does it do that or does it start again like this:

/˜\_/˜\ooo/˜\_/˜\_/˜\_/˜

Or am I not getting your question?

The shape of the LFO is not the problem, but the position within the bar. When i deactivate it (no matter for how long) and activate it again, it is at the wrong position, which means, the modulation sounds different/is at the wrong position. After restarting the sequencer, the position is correct again.

OK, maybe my example wasn’t too clear but from your description it sounds like it is restarting on reactivation. Which means it is going to be out of sync. Guess I’ll have to try this later.

EDIT. you inserted “no matter for how long” later. Is the LFO synced? If you set the cycle length to 1 bar with sync=on and phase=0, then deactivate it for 1 bar, is it at the wrong position as well? Could you share your LFO’s settings?

As said in the first 2 posts, the LFO is synced, in fact, going out of sync is the problem described ,)

i shared the lfo settings in the first 2 posts, set SYNC, dial in any phase and offset.

The important thing is, that we are talking about EFFECT lfos. Because they can be deactivated and activated again. But this is the problem: after reactivating, the position is wrong.

OK, yeah, sorry. I guess I’m too tired after work to remember anything longer than a sentence ago.

Anyway, I think I can confirm what you’re seeing. When toggled off/on the LFO will restart at that point and then stay synced to that point. If you rely on your LFO staying synced to the beginning of the bar it will sound wrong.
Here’s a workaround: insert a filter after your LFO. Instead of toggling the LFO, toggle the filter or change its CC range. That way your LFO won’t be affected. Unfortunately this doesn’t work with NRPN or CC-PAIRS.

(I wouldn’t call it a bug, actually. This is a good feature.)

Setting up a synced LFO, spending time to program the receiving synth, and then the LFO is all over the place but synced, i would def not call a feature :wink:

Well, the way it works, you can start/restart your LFO at any point or multiple points in a pattern by toggling it. If you want the LFO to keep running but “mute” it, use the filter effect. The latter seems to be what you want to do

No-toggling CAUSES the problem. Is my English so bad? :sweat_smile: you did not try it yourself yet, right?

And honestly i dont want workarounds especially not on machines that focus on one task and which i buy to escape from complicated PC way of working.

Like I said two posts ago, I did try it. I can see/hear what you mean. BUT I don’t think it is an issue. You should instead keep the LFO running like you set it up, then use the filter effect to mute it. Simple, really. I shouldn’t have called it a workaround. The way the LFO toggling works opens up interesting possibilities for when you do not want your LFO to always be synced to the start of the pattern. No idea how Squarp have intended this to work obviously.

The thread is called “LFO possible bug”? I say, probably no.

1 Like

If i want the LFO to wander around, then i don’t sync it. And if i sync it, then i want it to stay at a certain position.

Why can’t it just be what it is: a bug? It’s not a too big problem, as long as i know, it’s not a defect only in my unit.

Maybe Squarp should check the other modulations too btw, not that others are also wandering .

This bug seems to be fixed with the new firmware as far as i could check it today.

There were issues again when modulating the first LFO with another and then with another (that’s what tried today) then sometimes the connected synth stopped spitting out sounds, but i guess this was caused on the synth side.

Apart from that is it AMAZING what rhythmic variations of the modulations can be created by chaining synced LFOs (and then urning them off and on) . Very complex LFOs are possible… great!

1 Like