JU-06A "Drifty" Pitch & Tune Problems

I’m ~about a month into owning my Pyramid MK3 (absolutely love it) - I also bought a JU-06A at the same time. I won my fantasy football league, and these are my trophies :grinning_face_with_smiling_eyes: :man_shrugging: :joy:

I’m working on sequencing a song that has all the below synths on it via different tracks with the Pyramid and everything is working great except for the JU-06A. The JU-06A eventually goes out of tune/pitch and gets very “drifty” and sounds like crap when playing back the sequence or playing live via my MIDI controller. The only way I can get it back in tune and on pitch is by doing a factory reset, but eventually it’ll go out of wak again, particularly when I start playing around live with the tracks, sequences, and patterns I’ve programmed in the Pyramid. Every other synth is rock solid and playing back as I’d expect.

I’m assuming this a MIDI issue so tried the below, but am honestly wondering if there’s a ghost in the machine and I need to return the JU-06A for a different one? Per always, I’m sure I’m doing something completely stupid here, maybe you can tell me what.

Steps Taken:
I’ve tried different MIDI channels
I’ve tried different MIDI cables
I’ve tried different MIDI ports in MIO XL
Tried routing MIDI through a quadra thru instead of my mio XL

Pyramid MK3

JU-06A MIDI IN > MIO XL MIDI OUT (port 5) > Pyramid A

have you tried routing directly from the Pyramid to the synth sans interface or thru box?

@CreepyPants just tried that - same story as in other scenarios - works ok for a bit but then gets super drifty and just unusable. It’ll “work” for varying periods of time doing a variety of things - so nothing consistently is kicking it into “drift town” - it just eventually gets there - could be instantly, could be after 10 minutes - super frustrating when you think it’s behaving and are fine tuning and getting into a groove and then it goes “drifty” again. Thanks for the idea and reply though.

Oh, I know that one very very well.
Terribly terribly well, alas
(My issues are usually stupidity, tho - heh)

I’m assuming you have no CC’s on this Track and you’ve been able to duplicate this behaviour with a fresh brand spankin new project, so the next step I’d suggest is see if there’s anything weird coming from the Pyramid - as in beyond Note Data.

You can achieve this with the MIDI Monitor on the Pyramid - a super handy tool I keep forgetting about, so sorry if I bring it up and youve’ already been there. Barring that, if you have a chance to stick a MIDI Monitor in there such as MIDIOx that’d be nifty.

Since you’ve tested with no MIDI Input to the Pyramid and no router/interface, then we can rule out loops.
I’m also assuming you’ve tried with only Note Data and no CC events.

and I’m assuming this doesn’t happen when playing the synth solo hooked up to nothing

how bizarre and frustrating!

Edit to Add: and once it goes wonky, do you try to double or triple stop and does that ‘fix’ it? (Those send out All Notes Off and All Sound Off CC msgs. I wish there was a way to force a “Reset All Controllers” but maybe that is recognised on the synth side of things as part of the All Notes Off - I know that double/triple pressing [Stop] fixes my stuck notes if/when i have them)

1 Like

thanks again for taking the time here @CreepyPants :pray: Triple checked, no CC’s on the track, new project yielded same results too. Can’t seem to figure out how to use MIDI Monitor on the Pyramid, am I missing documentation on that (sorry!)

If I have the JU-06A connected only to the Audio Output on the machine, meaning no MIDI whatsoever - and play patterns or notes from the JU-06A the machine behaves (and sounds) perfect. When I introduce the MIDI is when things go south - again though, all my other synths are behaving perfectly so I’m fairly confident it’s not a routing issue. I have “Pocket MIDI” but can’t figure that out right now either (I should go to bed, lol).

I’ve just opened a ticket with Roland since I’m well w/in warranty - so maybe this is something they’ve tripped across already and have a solution. I don’t think this could affect things, but I did add some definition files recently, and I even wrote my first one for…wait for it, the JU-06A, could that be potentially a culprit here? That post is here, FWIW. Will report back if anything progresses.

@CreepyPants I’ve done some further troubleshooting here and think the issue is specifically with the JU-06A and the Pyramid. I’m guessing I should likely open an “official” ticket w/Squarp @ this point.

TroubleShoot Steps:
I plugged the JU-06A only into my BeatStep Pro (JU-06A IN -> BeatStep Pro MIDI OUT) and the JU-06A was rock solid, couldn’t get it to go out of tune and behaved perfectly.

If I play JU-06A plugged into no MIDI at all then it plays back as you’d suspect as well, sounds perfect.

It’s only when I introduce the Pyramid does it get wonky and go out of tune.

I then went from JU-06A IN -> Pyramid Out B so I was bypassing my MIO XL to keep things simpler for testing purposes - and then assigned the Track on a net new project on the Pyramid to “CH.6 B” and it’s out of tune from the jump :frowning:

I’m not really sure how to properly read the MIDI monitor messages on the pyramid, but am pasting the below in case that’s helpful. I currently have:

  • A OUT -> MIO XL IN (how all my others synths are connected)
  • B OUT -> JU-06A IN

What do you have connected to the Pyramid MIDI In? It looks like the Pyramid is receiving a bunch of Modwheel/CC01 data.

Can you try the same test without anything sending CC01 data to the Pyramid? Depending in your settings, this could be echoed out to your destination synth


Yup, synth going out of tune and incoming drunken modwheel CC messages present, look no further … than the source of those drunken modwheel messages.


You guys rock. I had my controller (MPK261) plugged into Pyramid IN which was sending the drunken modwheel messages - I adjusted some settings on the MPK261 and now the JU-06A is playing nice with all its other synth friends.

Because I have to ask, how come the drunken messages weren’t affecting other synths? Either way, thank god that’s solved - and it’s good for me to know and understand a little better how to use the MIDI Monitor (thx @CreepyPants) - great trouble shooting tool - am still earning my MIDI stripes as you can see - the “good” thing with weird issues like this is it forces you (see: me) to learn some stuff, never a bad thing. Thanks a million again ya’ll.

:pray: :pray: :pray:

1 Like

Glad you resolved this, and perhaps I should have been more strident in my response to ensure there’s no MIDI data coming IN to the Pyramid as I made that assumption with my second post above. Apologies. I might have saved you some of that hair you pulled out over the course of your frustrations! LOL

As for why it doesn’t affect other synths, could be a number of reasons:

  • Modwheel is not configured to do anything as significant on other synth patches
  • Depends on which Track is Active and what setting your have on MIDI In in the [2nd]+[FX] settings menus
  • Other settings and MIDI Channel stuff, etc, etc.
    blah blah blah

Moot points all, really.
And a learning experience for all!


1 Like

As a owner of the JU06A I thought there was something wrong with the device, but I didn’t experience the issue, so I am glad you figured this out. Most of the time the midi monitor is a blessing, since it can help you showing all that is going on on every channel. When you use a setup with different hardware (and a Mio device, which is great but need to be configured correctly to avoid cross-talking and unwanted messaging), then things get a bit more hairy :slight_smile:

1 Like

Lessons learned hopefully:
In case of problems like this, always first try with a minimal setup before blaming the machines that are “in between”


This topic was automatically closed after 21 days. New replies are no longer allowed.