How do i record CCs (modulation) ? ( i fail)


i´m not getting there, no sucessful attempts to record CCs (modulations).
( my querys are on the second part / first part describes what i´ve donne)

  • First: i setup my CC lane in a existing project / i set the CC # acordingly ( CC77 in my case now) / midi input is set to the correct inout/Device ( USB Host)
  • i press record, nothing…no data captured
  • different try: i first set manually a data entry / pressing a pad - works - i get the pad lit up ( ie. some data is entered)/ …trying from there to record:
  • nothing, no data captured
  • with one exeption: i just had 1-2 attempts, when CC77 was captured and recorded-
  • the first one, ended with the Hapax been frozen - completly / cold restart required ( couldn´t save the test settings)
  • set up again my settings: the second REC atempt that worked, i had just data in the midlle of the bar, but it would not record further, looping around from start was not working. record more or new data was not working ( might have been a settings issue vs. the looping / but which one ? )
  • further attempts to record CC77 did NOT work again.
  • all attnepts did not work, beside these two, …which were functionality wise, unsuccessful.

so here we go, - beside the initial setup of the project/track/CC lane- i need to ask:

  • what exactly do i have to do ?
  • which are the crucial points/settings ( clear is: midi input / create CC lane / set CC # acordingly )
  • where are stumbling blocks

sorry for long post. just trying to give the necessary infos

you don’t need to do any setup…

if you hit record and send cc’s, hapax will automatically create automation lanes as required.

you just need to make sure the midi input (source and channel) is set on the track.
(you can check this with midi monitor to confirm source and channel)

note : drum tracks, will only record CC from the midi channel

I can’t really think whats wrong, its always worked for me !?
I guess only thing, to check is that you dont have some midi feedback loop going on, that would create trouble.

also bare in mine if you loop around, it will record over the previous automaton , though you could turn this off in rec settings (stop recording at end of pattern)

1 Like

(i wrote a very long post yesterday, and virtually just re-wrote it again, while i wanted to keep it short)
( Mark, you can easily omit reading this post and just turn to my questions / marked 1. 2. 3. 4. / that would do allready) but in case you like to:

ok, this thing is a very strange problem.
some definitly not related to user error, since i did not touch the Hapax at all, while the hapax switched something
I have some question, found at the very end, where you could help me out…to continue on this, please.

had today also a very strange problem:
my main project was empty,…i HAD to guess that i accidentally have saved, but without loading the pattern…i´ve shut down the hapax…to start later on a new session:
i thought, ok, programm it by new,
and suddenly the whole project was still there. all fine.
…well ( a thought that just occured right now ), seems it just did not load the project, while the “progression bar” would show its all fine. maybe i missed to watch the “load progress” to its end…’ (details,…finally to file under “user error”,…much likely. “somehow”, at least)

fact is: i´ve NOT managed to this time to record any CCs or any CVs at all.
it never worked exept of the two very short moments, decirbed in my post 1

all my tests yesterday were then related to check out all my connections and settings,
which lead to very strange behaves, failures and total confusion.

i take it from your post that the automation process should be as simple as recording notes.
But it is NOT for me !
…the cause, i still have to figure out.

the midi controller LCXL(launch control XL) is connected to the same midi input ( USB Host) as my masterkeyboard ( in exchange, by swapping the connections)
yet, yeterday was my masterkeyboard also not running !

i found then a (midi) settings page where everything was set to off.
i activated the port, then was my keyboard working.
Well, it was a forth and back since iirc.
…then the strange failures occured ( related to track mute/unmute states) ( since my test instrument is in the computer (in GP) , i was still on it to programm the midi connections in GP…into my existing patch there) ( a muted track begun to play, …while i could NOT make it play again at all, just a few moments later,…while doing all sorts of checks, button presses etc. )

then, i did not found this midi settings page again, when i wanted to check back there again.
right now i´m not shure if i was just in the “midi-thru” settings dialog, or not. (vs. that “settings page” i found)

what you could help me for now is:

  1. is there any other midi settings pages other than found in “settings” ?
  2. is there any “second level page” settings available there, a level deeper ?..button combo ?
  3. is there any midi settings page available at all, where the INPUTS as such can be set to off ( marked = ----- )
  4. with “midi monitor” you meant the common view on the display on the right side, or is there something more ?

( my mute state problems yesterday “could” indicate that i have a problem with this row of buttons, btw. / i find i have since begin “funny moments” with that row of buttons / yet my “modulation record” problem is something entirely different ofcourse)

sorry to steal your time ! its very hard for me to keep this short. so its even much more appreciated having you here, assisting us !!..baybsitting, haha :laughing:
Can´t express my thankfulness enough / Makes a difference (in “such” moments), having such a support !

  1. only one I can think of is setting->midi input… where you can tell it to ignore certain midi messages (eg) CC… oh and separate sync settings for midi clock
  2. not that I can think of, really is just the above and midi channels/ports on track input / output
  3. no… just the midi input for messages as per 1.
  4. 2nd + LIVE = midi monitor

what could be worth doing is ‘resetting’ your hapax.
basically back up your SD card to your computer (i.e. copy files), the you could erase/format the sd card.
(really we are only deleting the settings file though :wink: )

this will mean , you will be back to factory settings, just in case you have something weird going on…

though as above, I really can’t think what you could turn off… even the settings->midi input, is clear if you are ‘ignoring’ messages, so cannot see how that could be ‘wrong’

1 Like

thank you !
a will give it a look this week