Hermod Stuck notes OS 1.71

Have reached out to Squarp support but never recieved any response, hopefully the forum can help.
Whether I am sequencing internally, or sending midi (usb or din) If i change to a different track on the hermod, either with the encoder or the button combo, the hermod will get stuck on the last note played. From then on any time I scroll through the tracks with the encoder, the hermod triggers a note and stays on for every track that I scroll through. Midi settings Active track is set to off, no effects enabled on any track, and even if I mute every track just scrolling through the tracks with the encoder lights up the track led, triggers, and hangs the last note. Tried multiple midi devices for sequencing, hermod has the same strange behavior. Only way to stop hung notes is to reset the track mode layout to single mono voice. But then if I scroll the encoder to a different track the same stuck behavior happens again. Ive reinstalled the firmware multiple times to no avail. Is anyone else have an issue of stuck notes while changing tracks?

wow, that sounds completely unusable…
Ive never seen anything like that on my hermod… I doubt others see the same, otherwise the forum would be full of posts about it.
(issue is, I really can’t see anything in your post that is not ‘normal’ everyday use, that we don’t all do each day)

if you have tried latest firmware (though, Ive not seen that on any firmware version) , then all I can think of is to remove the sdcard , back it up , then delete it contents.
this will mean you don’t have any ‘settings’ (though Ive no idea what would cause this)

( the only thing, that later you might want to restore from the card is the calibration file … but the defaults will be ok for testing)

apart from that I wonder if there is some kind of hardware fault - in which case, Squarp via the contact form is really where you need to persist.

Im sure they are pretty busy at the moment, what with the Hapax release, and firmware updates… and I think they are going to Superbooth, so are likely preparing for that…
so perhaps reach out again to them, in case somehow your issue has been overlooked.

1 Like

Thanks for the reply, it’s the heart of my system and has become unusable as you stated. I will try all you suggested and hope that its a software issue and not hardware. I’ll report back my findings.

@thetechnobear Nothing seems to resolve the issue, Ive tried all the firmwares available, a brand new SD card, every combination of settings I could think of…
But in doing so Ive narrowed down the issue: Essentially if I use the encoder to switch tracks while holding down a midi note, that note will become stuck and play on every subsequent track I scroll to. It’s as if the active channel is stuck on and carrying the incoming midi to any channel regardless of my controllers settings or the Hermods. This is happening across firmwares, so Im at a loss and assuming its Hardware? Very Strange.

1 Like

If you narrowed it down to selecting tracks: do notes get stuck too when you switch tracks with the → holding “TRACK” button and the corresponding Pad – combo?

That way feels a lot more hands on and precise to me anyways :slight_smile:
Would be interesting to know

1 Like

I agree @nemoy, Those button combos are quicker and I enjoy them aswell, but Unfortunately yes the same issue happens with them, notes hang. Just curious, but does anyone else’s LED’s for the track they are selecting glow bright when its selected? If i scroll or use the button combo, the track’s LED I select lights up brightly, as if there is constant cv output coming from the act of selecting.

Been doing more investigating.

Firmwares v1.3 to v1.5 do not respect any pitch information, there is no way to affect pitch via internal sequencer or external midi. Triggers work fine, all other functionality seems normal, there is just no way to control pitch.

Firmware v1.6 and v1.70/1.71 respect internally sequenced pitch and external midi, but the issue of stuck notes is present, anytime a midi note is held it sticks across any track i scroll or button combo to. I usually test this with Active Channel off. I discovered that when Active channel is ON, the active channel functionality works as expected, switching tracks does not hang notes. But If i send midi on a channel that is NOT the active channel, those notes will hang if I change tracks.
example:

  • active midi channel set to 1 > press note on track one and scroll to track two > track one stops playing and track two plays the note being held. as expected
  • active midi channel still set to 1 (or active midi channel off) > press note on midi channel 2 and scroll to any track > all tracks play note being held.

Something Strange has happened in the change between firmwares v1.5 and v1.6
What I need is to do a complete factory reset. Deleting the contents of the SD card doesn’t cut it. Ive done this multiple times including reformatting the sd to Fat32 and replacing it with a new one altogether. I notice that booting with an empty sd loads the previous firmware installed. So I assume there are files and settings on the device itself that are not being reset with deleting the contents of the SD card.

Is there any way to completely wipe my Hermod to start fresh? A button combo on start up? Or a way to boot into it with my computer? or maybe access to Firmware v1.0 and update each one at a time incase something got lost in leapfrogging a firmware?

This Module is crucial to my setup and I am desperate to find a solution. No word from Squarp support yet, Im sure they are busy with Hapax stuff.

Update for anyone else experiencing the same issue:
Been in contact with Benoit at squarp. Discovered a bug in os1.71 and should be fixed in future updates.

1 Like