Hermod resetting issue

I’m encountering an issue where Hermod randomly resets after trying to go to a different mode.
I haven’t been able to find out what’s triggering it, but when I flip between modes, sometimes it’ll completely reset.
Sometimes it happens after working for a few minutes, and other times it happens on the first mode button I press after powering up.
It started doing this recently, so I don’t know what would’ve caused it.

ouch, that doesn’t sound good :frowning:


things I would try are:
a) new project, from scratch - do not load a template project (hold step at startup - iirc)
possibly its a corrupt state in a project.

b) format sdcard, try fresh sdcard … just in case of corrupted card
though seems unlikely, as it only uses the sdcard to load project not whilst editing/playing.

c) load/re-load latest firmware
again, off a fresh sdcard - just in case.
(worth a go, but firmware are checksummed, so seems unlikely its a corrupted firmware)

really thats all you can do from a ‘software side’ (that I can think of now)

on the hardware side…
i’d test to see if its a eurorack power issue
first try hermod on a bus board on its own. (so disconnect all other modules from bus)
if that doesn’t change anything, try the hermod as the only thing connected in the rack.


I’ll be honest, I don’t think its likely the above will solve the issue - but its needed to diagnose things, to isolate it to the hermod - and Squarp is likely to ask you to do the above.

unfortunately, if none of the above helps… it sounds like a hardware issue,
so you will need to report this via the Squarp website for help, and they will let you know how to proceed.


general note: all suspected hardware issues should be reported diirectly to Squarp via their website contact form (see above) - Squarp will be able to help you diagnose, and also detemine if repair/replacement is required and procedure for doing so.

1 Like

Thanks for the help!

Yeah, I’ve tried pretty much everything.
Starting from a new project, wiping the card, and loading old firmware (but I’m back on the latest now).

I tried moving it around my case, and removing all other modules, but it’s still happening.

I’ll reach out to Squarp and see if we can solve it. Thanks again! :smiley:

1 Like

You’re welcome , I hope you get it sorted out swiftly

1 Like

I have the same issue unfortunately, normally when I press the Step button it will reset.

I’ve made sure firmware is latest (it was happening on previous version too), I’ve changed SD card, I’ve put the Hermod in a different case with a different power supply, I’ve reset the project, I’ve tested it with and without anything connected etc, still happens. I’ve contacted Squarp so hopefully they will be able to fix it.