Hermod pitch CV output appears way off

I found that the pitch CV output from my Hermod is very low. I have tried to align the CV outputs from my Pyramid and Keystep with the Hermod but it is not working.

Pyramid default setting for CV out is 1V = C3
This aligns with Keystep setting for CV 0V = C1
Hermod CV output is much (several octaves) lower. The only setting I can find is in the effect => midi => root note. This is set to 60 by default. I can raise the root note to 86 and this is makes it almost the same, but it is detuned noticeably :frowning_face: Also raising the root note limits the pitch range since the midi effect will not pass notes higher then 120, so this really should be solved somewhere else, but there appears to be no setting for this.

Are there instructions for calibrating the CV outputs? I thought that an advantage of digital modules was that they don’t have to be tuned… :thinking:

this is by design…

the pyramid is limited to 0…5v, so can only cover 5 octaves - a small portion of the midi scale (0…127)
(I suspect your key step is similarly limited) , so it makes sense to put the voltage in a nicely useable range.

the hermod is -5v to +5v, so can over 10 octaves, so covers the full midi range (pretty much, 0…120), or C0 to C10, so therefore 0v has to be C5, to make the full range available.

if this is inconvenient then sure you can shift this, by moving the root note, by a multiple of 12, so 72, or 84.
yes, you will loose some range - but thats due to the limitation of midi and v/oct.
I guess in practice this doesn’t matter, as you can do it by track…

but for me, I dont think this really matters, where 0v sits in modular is pretty irrelevant given every (?) oscillator has a course tune knob, and many only respond over a small voltage range for pitch anyway
(e.g. mutable is only 8v -3v to +5v)

if your oscillator doesn’t have a course tune then you can always use an offset module.

sure digital is doesn’t need tuning, but the conversion to analog voltage can … as soon as you hit the analog domain variance start to creep in :wink:

note: as discussed above, this won’t help your ‘issue’ , rather this is used for small offsets, or scaling issues.

calibration is covered in the hermod manual
https://squarp.net/hermod_settings

note: I personally avoid this, as you can only do calibration as well as your measuring equipment is capable of, imply you need a well calibrated oscilloscope or multimeter… so Ive hoped/assumed that it was calibrated factory when it left the ‘factory’ :slight_smile:

1 Like

Thanks Mark for the explanation. I now found it in the manual too.

It makes sense. I never really thought about the 5V = 5 octaves limitation. Although I think I would still prefer to keep the output of the Hermod cv a bit closer to my other equipment so that I can tune an oscillator and switch cv sources without having to compensate 5 octaves. My oscillator with the widest range seems to cover about 7 octaves.

When using the Hermod simply as a midi to cv converter, you need to transpose the midi sequences before hitting the Hermod. There is no simple way to make up for the 5 octaves, and raising the midi root setting quickly clips the incoming midi notes.

But I’ll have to wrap my head around this first to see what’s practical. With most oscillators it’s easy to adjust the coarse tuning, but for example my OSC303 oscillator only has about 2 octaves to go up. I will consider an offset / precision adder module. I think ALM makes one.

I took a shot at calibrating the CV output. The manual doesn’t say much about it, but it seems easy enough because it appears you just specify an offset in 1V steps. However, if I follow the instructions on the screen and press X to save, nothing seems to have changed…

Can anyone tell me how this calibration process is supposed to work?

yeah, I had a play with this, and I think your right, it actually feels a bit like a bug…

to me it feels like root note is working the opposite to the way it should do,
Id say root note should be 0v, so midi note 60 (C4) = 0v

but currently if you want C0 to be zero volts, you have to increase the root note, rather than set it to 24 which is what you’d expect… and this is why you are running out of range.

more generally, I agree we should be able to set it such that it can take an input of C0-C5 and output, 0v-5v as this is the same as on the pyramid.

(interestingly, I found a similar (and reported) issue with the Pyramid which was fixed for OS 3.1)

I think this is something definitely worth reporting/discussing with @squarpadmin via https://squarp.net/contact

1 Like

hmm, ok, played with this a bit more…

and some conclusions

I think @squarpadmin are using ‘root note’ to mean some kind of ‘transposition’, but honestly it just makes my brain hurt if trying to describe that in words… beyond the idea of increasing the number lowers the 0v reference.
… and that is not good. (hell Im a developer, i usually eat this stuff for breakfast :wink: )

also I think its really a bit bad its now explicitly talking about 0v or 1v level…
in fact, whilst the manual says 0v = C5 thats actually not true, midi note 60 = C4, and measuring the voltage that is 0v.

so I think this is
a) poorly documented
b) its unintuitive

BUT is it limiting us…

I thought it was initially, but now Ive realised its not… and that again is proof of how unintuitive this is!

lets take the example, where we try to match up the Pyramid,

on the pyramid I set 1v= C1 (awesomely, Squarp fixed this in 3.1) , so C3 = 3v C5=5v

so on the hermod by default C3,48 = -1v (C4,60 = 0v)

to do this on the hermod, we need to raise the 0v reference by 4 volts, so increase by 4 octaves, so set the midi note to 108 (C8) … this is why its unintuitive, what does C8 have to do with what we are doing :wink:

anyway, now C3 =3v , and of course just like the pyramid we can only go to 5v , so are limited to 2 octaves.
but thats a limitation of having -5v to +5v, nothing else.

… of course, C3=3v is the extreme (max that the pyramid will allow), if we have C3 at a lower voltage reference then its all dropped down, and we get more range.


what i think we are really missing (and is present on the pyramid) is the ability to transpose the incoming midi,
i.e. to be able to play C3 on a keyboard, but for it to transpose that automatically to C5, so we can maximise our voltage range.

(also, unfortunately unlike the pyramid, the scale effect does not have a chromatic scale, to allow us to just transpose the midi)

1 Like

Thanks so much for diving into this!

I was having a really hard time trying to wrap my head around how things work. It’s a relief to know it’s not me but a bummer that this appears to be an oversight in the implementation.

Erm NO as in 1.21 the Scale effect has Cromatic tuning! Go to Color turn to Intervals. Go to Scale turn to Cromatic. Thr Scale Effect had the most pleasant changes within the last two updates mostly undocumented.
But i see your frustration with Root Note :smiley:

2 Likes

I looked for it, didn’t think to check intervals :slight_smile:

Cool, so at the cost of a effect that solves the issue.

1 Like

Thank you for explaining this! I’ve been struggling with this issue for a week.

I don’t see how the chromatic scale effect is solving the issue. It can only transpose 12 semi tones up or down. I am looking to transpose 4 octaves. Did I miss something?

1 Like