Hermod MIDI on Windows?

Anyone having issues getting Windows to detect Hermod as a midi device? Running windows 10 with hermod connected as a USB Device but the computer doesn’t see it. Not sure if i’m missing a driver download or something

No drivers required - It’s a usb midi class compliant device.

Try another cable?
can’t really think what else to try.

Does that t just not appears as midi device… or is it not listed in device manager at all?
What firmware are you running?

I can concur that more often than not, the issue is due to the cable.

Also, Windows can be a bit capricious with USB devices sometimes, and turning the computer off and on again might sort out the issue.

tried with two different cables, neither worked. both worked fine connecting Hermod to an ipad and a mac. Tried restarting the PC as well, no joy. any thing to try next?

I have this same problem; had to downgrade to v1.30.

did this help?
(what version were you on prior to this?)

I have not tried downgrading yet. Currently running on 1.42

Yes it did; no problem whatsoever after downgrading. I was trying v1.42 for the first time when this problem happened.

1 Like

Hi @Sonoridades,

We’re going to contact you by email. We’d love to have your help on this matter, as we cannot reproduce the error, even on our Windows machines.

We’ll send you unreleased working versions of hermodOS, dating back in between 1.30 and 1.42, to try and pinpoint the issue, in order to fix this regression in an upcoming hermodOS release.


1 Like

I was able to replicate this as well by downgrading from 1.42 to 1.30 and then going back. 1.30 is detected on windows correctly (seen using Ableton Live 10), whereas 1.42 does not. Happy to help experiment further if needed.

Happy to help too.

1 Like

Hi everyone,

I did a bunch of tests, upgrading/downgrading versions, etc., and I think I found the root of the issue.
Windows tries to “remember” devices in the device manager. Between 1.30 and 1.42 we did change some minor details in the USB descriptor to improve compatibility. What that means is that before Windows “thinks” it knows Hermod inside and out, when really it has changed, and then Windows gets confused when Hermod behaves differently.

TL;DR: Here is he procedure that reliably solved it for me:

  1. downgrade to hermodOS 1.30, or whichever hermodOS works in USB device on your Windows
  2. Connect Hermod to your computer
  3. Open Device Manager on Windows (fastest way is just to hit the windows key and start typing “Device Manager”, it should appear in the fast search results)
  4. Scroll to the “Sound, video and game controllers” category
  5. Locate the device called “Hermod”
  6. Right click > “Uninstall device” and confirm
  7. Disconnect Hermod
  8. Upgrade Hermod to the latest hermodOS
  9. Connect Hermod to your PC

It should be recognized.

@nsolarz, does that work on your end ?


Hi Thibault

Doesn’t work for me. Windows recognizes version 1.3 but not the last version (1.72)

Windows has some quirks with regard to device drivers. It tries to “remember” some devices, but as soon as the slightest thing changes in the USB descriptor, fails miserably.

You might want to try the following options.

Option A

  1. Upgrade to 1.72
  2. Open Device Manager
  3. Plug in Hermod
  4. Locate the “unrecognized device” that appeared.
  5. Right click oon it, and uninstall driver
  6. Reboot
  7. Plug Hermod back in

Option B

  1. Downgrade to 1.3
  2. Open Device Manager
  3. Plug in Hermod
  4. Locate Hermod
  5. Right click on it, and uninstall driver
  6. Reboot
  7. Upgrade to 1.72
  8. Plug Hermod back in

Let me know if that helps

Nope, I’ve tried both methods and it doesn’t recognise it when it’s upgraded.

When upgraded, in the port section of the device manager an error shows up:

Martel USB to Serial (COM6)

This device cannot start. (Code 10)

A device which does not exist was specified.

thanks for your answer and sorry for the delay

It works perfectly for me but the USB is built into the motherboard. Do you need an update of the device driver? It sounds like the Martel USB might be an after market product.