Hermod/Keystep track 1 not working


#1

Hi there,

Just got a Hermod and I have a Keystep plugged into usb host. Keystep is set to MIDI channel 1 and Hermod is at default settings. For some reason, Hermod track 1 will not receive any midi data on track 1, but all the other tracks work fine. Any ideas why this might be happening? Thanks!


#2

I had this happen too, and had to change the position of the white switches on the back of the Keystep - put both the switches down (so “internal” setting). That did it for me.


#3

Just tried it with all four dipswitch settings but unfortunately nothing has changed, appreciate the feedback though!

So far I’ve tried reinstalling the latest firmware and have tried two different cases/power supplies but can’t seem to fix it. I thought it might be something weird with the Keystep but midi channel 1 works just fine with it plugged into my Digitone.


#4

Just tried the same thing with Digitone and have the same problem…


#5

How are you connecting your Digitone to Hermod?


#6

Digitone was with a midi cable directly into midi in.

I decided to try downgrading to an earlier firmware (1.10) and strangely enough everything works fine. I’d definitely like to be using v1.3 though. I’m waiting to hear back from Squarp about it but I find it really odd that I’m the only one (who has documented) having this problem with the newest firmware!


#7

Isn’t track 1 set on channel 2 by default? Track 2 on channel 3 ecc, Channel 1 transmit midi on the highlighted track in track view. Maybe I’m just pointing out the obvious and you looked that up, as I understand you even downgraded the firmware


#8

It is, yeah. Channel 1 is active track, channel 2 is track 1, etc. Everything works fine on channels 3-9 (tracks 2-8) but with channels 1-2 I get no response.


#9

Hmmmm - this might be a stupid question but do you have the clock on TR1? If so that renders TR1 out of action.

Go to Track > Settings (Y button) > Clock


#10

Ahh that was it, thank you so much!!

Sure enough I had my cv clock out set as G1+RESET. I feel dumb but very glad this is resolved!


#11

:+1: Nice