Hermod is freezing, duplicating saved projects, and other strange behaviors

I have a Hermod and am liking it. But the past couple of days it’s been giving me a fair number of problems.

  • It’s frozen badly, twice, so that it’s unresponsive and I have to turn off the modular and turn it back on to get it to work. Once this was while I was saving a sequence while it was playing, but other times not.
  • I saved a project last night. I came back today to see it created a duplicate of that project, same exact name. I load the project. On one track the gate worked, but the CV didn’t: the notes were super high-pitched and only one note. Nonetheless, the note info in the STEP display was correct. I copied the STEP events to a new track, and it worked OK. I copied them back to the first track, but same problem. I checked to make sure the base note for the track wasn’t set very high. It wasn’t.
  • I opened the duplicate of that project and it worked fine. I added a new sequence and then went back to the first sequence. Now the same problem as per above: a single note playing over and over, very high. The STEP display showed everything was normal, though. I saved this project as a new project. Again, it made a duplicate.

Has this sort of thing happened to anyone? What should I do?

Perhaps a firmware issue? I don’t know what version firmware I’m running because I can’t find how to display it in the manual – the Hermod is from March or so, so I suppose it’s a bit out of date. It obvious where the SD card is and how to extract it? Any videos online of the process?

Sounds odd.

firmware version is display when you power up hermod.

updating firmware is simple,

  • sdcard slot is on back of module
  • take hermod out of your rack ,
  • pop out sdcard, put into sdcard reader/writer
  • copy new new hermod.bin (from website) to sdcard (overwrite existing one)
  • put hermod back in rack
  • power up whilst holding encoder down

its unlikely to be firmware, as none were ‘that bad’, but worth trying, as its easy.

If you have issues with projects (e.g. duplicates), Id first point the finger at the sdcard, so try another one.
It shouldn’t cause freezing, but its possible - perhaps if corrupt data.
so yeah… Id probably do that before updating firmware ‘just in case’

of course, its possibly you may have found a bug that causes freezing, but if its just ‘general use’… the question is why do others not have issues - the hermod has been around a long time, and we dont see regular reports of crashing (I cannot remember mine crashing in recent years :))

to check for a bug, you’d need to find a reproducible scenario i.e. I do x, then y, then z…
to kind of prove its not a random ‘hardware issue’.

and that bring us to hardware…
for freezing the other possibility is eurorack power issues, all digital modules are pretty sensitive to power.
specs are:

  • Requires a ±12V eurorack supply (consume 310mA from the +12V rail and 30mA from the -12V rail)

BUT make sure you are WELL above this… you can’t run anywhere near what eurorack power supplies SAY they can do … 20-30% is considered a typical required headroom.
(it varies though, as some are better/worst on their specs … as are module consumptions)

that said, usually, issues happen when powering on, due to so called ‘in/on-rush’ current.
basically, modules pull a lot more current when you first power on (particular digital but not exclusively), and as they all do it at the same time… you get a pretty big spike, causing a voltage drop, and if digital modules dont get the required voltage they can often misbehave in ‘wierd’ ways.

as I say, most likely on power on, but you can also get power issues caused by other modules spiking in use etc… and that would freeze modules.

btw: its NOT the last module you add that causes the issue… is the combination, so perfectly working case may fail when you add a new module (and its not necessarily that modules fault)

unfortunately, not easy for a user to track down this issue… (as you don’t have a way to measure current usage / voltage in the case easily)

so the ‘normal’ way, is trial n’ error… to take modules out of the case, and see if it goes away.
to shortcut, I usually try the most power hungry modules first… esp digital modules, and depending on your power setup, sometimes, it can help to move things to different rows/bus boards.

if that fails, unfortunately, you have to the more thorough route… which is a bit time consuming.
you have to empty the entire case, add problematic modules one at a time, and see when it starts to fail… but of course there are many combos required to track this down.

Its a pain… but eurorack is likely that, its a pretty ‘dodgy standard’ in many areas, that allows modules to interfere with each other (noise/power) … but what it lacks in quality, it makes up for in diversity :slight_smile:

anyway start with firmware and sdcard as they are quick n’ simple.
then play with power if you are still getting freezing.

good luck

remember: if you think there is a bug , or you have an hardware issue you can report these via the contact form , which is how Squarp provide official support.

Thanks. I will try updating the firmware and the SD card. What kind of SD card exactly do I need? Size, speed? The SD card that came with the Hermod is 1GB, no brand name. I have a “SanDisk Extreme 32GB” (https://www.amazon.com/SanDisk-Extreme-microSDHC-UHS-3-SDSQXAF-032G-GN6MA/dp/B06XWMQ81P). Would that work? (Apparently one can’t get SD cards smaller than 32GB these days) Would the current draw from this SD card be the same (or similar) to the one that came with the Hermod?

As to hardware – the Hermod is running in a Doepfer Monster case with 2 PSU3 power supplies. The PSU3 (Doepfer Homepage English) which provides “2000mA@+12V, 1200mA@-12V and additional +5V with 4000mA”. I have only digital modules on the power supply that the Hermod is on: an Expert Sleepers DistingEx next to the Hermod, a Synthesis Technologies Cloud Terrarium and a Morphing Dual LFO, as well as a TipTop SD808 above it. I attach the ModularGrid representation of the module layout. These add up, according to ModularGrid, to " Power Consumption: 654 mA +12V | 132 mA -12V | 0 mA 5V". Again, since these modules have their own PSU3, I’m getting 2000mA@+12V, 1200mA@-12V and additional +5V with 4000mA. Thus I’m not getting anywhere near the power ceiling. (There are other modules in the MonsterCase but they are on a completely separate PSU3, so they don’t draw power from the PSU3 the Hermod is on, and they don’t share a bus with the Hermod They are also well under the PSU3 limits, for what it’s worth.)

Since I’m way under the power supply limits, it’s not reasonable in this case to dismantle the modules even if the firmware and SD card changes don’t work, since the modules almost certainly can’t be overloading the power supply. As to start-up power draw: I purposely chose modules that do not have – as far as I know – any weird startup power supply needs. (In fact I asked a well-known case and power supply maker what brands of modules I should look out for with regard to high startup needs, and he told me a few brands/modules which do draw a lot of power on startup, so I avoided those brands/modules).

As said, I will try what you suggest with the firmware and SD card. Hopefully that works. If that doesn’t solve it, we’re probably looking at a problem with the unit itself. We can address that if the firmware/SD card changes don’t work.

This sounds like the issue that I’ve been running into over the past few weeks. I’m running 1.72, and whenever I run a chain of sequences (1>1>1>1>2>2>2>2) in one of my projects and let it loop, it consistently causes Hermod to freeze. These sequences are more complex than the ones that I previously made as I’m using all 8 tracks - 2 are sending MIDI CCs out on the same MIDI channel and 2 others have CV A modulating a single effect.

Most of my previous sequences were basic with very little MIDI but always separate tracks going to distinct channels and very little use of the CV matrix. Before this issue occurred I thought that my Hermod was a tank. I’m really hoping that the get this sorted soon.

as I said, If you can get it to consistent freeze e.g. with same project running, then its possibly a bug.
in that case, definitely file a bug report via the contact form.
Then Squarp will reach out to you, if they more details e.g. the project file.

as for power, as I said this is for random freezes with no apparent common theme.
Im also not saying it’s common.
however, you are more likely to get such issues whenyou have just added a new module to your rack… so its worth mentioning - ‘just in case’ to avoid a potentially very frustrating experience!
of course, no idea, in this case or others, as its entirely dependent on users case/psu/modules.

given other issues, Id say sdcard is first thing to try.
OP - not sure if there is a max size, I only use small sdcards as the projects size is tiny…so it’s a waste using large cards. need to be FAT32 iirc … in the manual?

of course, could always be an issue with unit, but thats less likely… than any of the above. (but not impossible!), again that can be resolved/discussed with Square via contact form.

This sounds like the issue that I’ve been running into over the past few weeks. I’m running 1.72, and whenever I run a chain of sequences (1>1>1>1>2>2>2>2) in one of my projects and let it loop, it consistently causes Hermod to freeze.

That’s what it is then. I have the exact same situation. Whenever I want to loop a sequence for a certain number of bars (eg 7), i need to use the sequence page and loop the sequence (eg 1>1) , then set the number of bars in the loop parameter. I have all 8 tracks in use, on track 4 i use both CV and midi out, track 8 has clock and reset out on the CV and midi out to a polysynth, i use a midi controller on midi in, a midi controller on usb host port. When I use the loop trick to loop a sequence it freezes randomly. I didn’t address this issue immediately cause i recently changed the PSU( but I’m using 1.5 ma out of 2 ma the PSU has) and i too though that could be the problem. But now I’m pretty positive it’s the sequence loop, cause without it it doesn’t freeze

(i sent a feature request to let the loop parameter work without having to chain sequences, as most of the time i just want to loop 1 sequence for a certain number of bars, but it never was implemented. It would be very useful to modify a sequence on the fly without having to chain it to itself (eg 1>1), also because when you are viewing a midi FX to modify it and the sequence restarts, it automatically kicks you out in the midi page or in the track page, which makes sense if you are chaining different sequences, but when I loop the same sequence i want to be able to work on the midi FX without being kicked out of the midi FX anytime the sequence restarts).

I ended up filling out a bug report and uploading my project. No response yet, but @bucio you should consider doing the same. I know from my day job that the more opportunities a developer has to reproduce a problem, the more like they are to fix it.

(I do like the idea of being able to loop sequences for exactly the reasons that you stated. Maybe I’ll create my own feature request and see where that gets us.)

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.