Hapax not updating bin file

So I just got myself a Hapax (stoked!). It came with OS 1.12 & an unmarked SD card inserted. Noticed it’s still on OS1.12 so I tried to update to OS 1.13 but the update fails.

I’ve put the bin file in the card’s lowest level (it has no folders), held the main encoder while turning on. The displayed message is:


On reboot the settings still show OS 1.12.

Is the ‘file note found’ a typo? Seems like it should be ‘file not found’.

Did you unzip the file? It should be on the root folder of the SD.

Hi @unfolding ,

You can try reformatting the SD card, then trying the update procedure again. If that fails, you can try with a different SD card. Please note that the bin file must not be renamed, and the SD card must be properly ejected from your computer before unplugging it, to ensure the bin file is not corrupted.

If that still fails, there might be a hardware issue on your Hapax. To verify that hypothesis, you could try going into SETTINGS > SAVE, and see if that works. If it does, then the integrated SD card reader works as intended, and more troubleshooting should be done.

If it does not work however, we might have to service your unit. If it comes to that, for privacy reasons, I recommend you contact us through the contact form to open a customer service ticket:

Oops, good catch.


this is a good company that stands behind their product. i cant wait to see what the future holds!


Hi Thibault, thanks for the really quick response (and sorry for my slow one). You were spot on about reformatting the card, I used the one supplied with the Hapax & it worked as intended.

Glad it was a super simple fix, much appreciated!

True story, that’s why I bought the Hapax.

As a long time Pyramid user I was blown away by how easy to learn & fast is to use the Hapax is. The Pyramid took me a few months to click with, but on day 1 with the Hapax it felt like any function or idea I wanted to try out was just there & easily to achieve.