Hapax and MPC (One, Live, X)

Anyone using the Hapax to control one of the newer MPCs?

I cannot for the life of me figure out how to use the Hapax to control my MPC One and use the MPC essentially as a self-contained sound module. I’ve seen some videos on it, but each track on the Hapax seems to be triggering all channels, like they are merged, even though I have made sure each track on the MPC is not on “merge” and has its own separate midi channel which corresponds to the midi channel on the Hapax. I also turned off “Master” in the Midi preferences as suggested in a Youtube on the subject, but it didn’t help. This is happening whether use DIN Midi or USB to connect the two. Any suggestions or resources would be greatly appreciated.

PS: I am not having this issue with any of the other multitimbral boxes I own. I want to figure this out with the MPC so I can bring them to the cabin (where I am now) as a standalone little studio.

i haven’t set this up with Hapax yet but it was working as you intend with Pyramid. are you sure it shouldn’t be set to Merge, instead of Auto, in the MIDI Track settings?

I’m sure you’ve thought of this, but you have the midi in specified on each track on the Hapax as well?

@chrisroland I tried Merge, Auto, In, and Off and it does the same thing (does nothing with Off).

@Seteef Yes, I do have the midi channel changed in each track on the Hapax, so it corresponds to the Midi channel of the track on the MPC. Also, like I said, I have no problem doing this with my Kronos, JV-1080, Analog Four, or other multitimbral instruments. it should be a no-brainer, which is why I am asking here.

Cool. I actually meant specifically the Midi In channel. I’m sure you do. I have weird behavior if I’m not specific with that, even if I playing the isomorphic keyboard.

Okay, that specifically never mattered with my other gear, but worth a look. I could see how it might be important for USB since it is bi-directional, but can’t see how it would matter for DIN Midi, since there is no data going from the MPC to the Hapax (only using Midi DIN out on the Hapax to Midi DIN in on the MPC).

Yeah, I would seem like it wouldn’t matter, but being in “All Active” mode, which is the default, means that maybe the MPC is listening to every active track (unless the other ones are set to certain midi channels)…I think…I don’t know. I just know that I have issues when I leave any channel in All Active mode.

So I just have it set up so I have to change channels on my Keystep when I change tracks. One extra step, but quick once you get used to it.

Problem solved. I looked through the manual and saw what I was missing on page 157. After setting the midi configuration according to a Youtube video, I’d been using the “Main” window (silly me) for adding tracks and assigning programs. Fine so far. Turns out, you have to then go to the “Track view” window to manually set each track to a specific midi in port. Maybe that’s what you guys were saying. I just didn’t know I had to go to an entirely different view. Now that I understand the workflow, I suppose the track view is a bit like a very narrowed down “inspector” window like in Logic. Anyway, was just able to create a song using 6 tracks on the Hapax, with a drum track, three plugins and two multi tracks on the MPC. Thanks for the input.



The reason I bought the MPC is that it can do so much in so many different ways. One of the reasons I rarely use it is because it tries to do so much in so many different ways. It’s UI is not necessarily difficult or counterintuitive (like the OT), it just seems to lack integration. Anyway, shortly after figuring out you really have to switch between two screens on the MPC to get it working with the Hapax, I bricked the MPC (for now) when I decided to upgrade the firmware. Doh! and its the only dedicated sound source I brought with me this week to the Cabin. I know, first world problems.

Just to add that you don’t have to go to track view to set midi in channels. In the main view, hit the little eye icon to reveal the track’s fader. Tap the midi icon, now you should be able to set all midi related track settings right there.

Thanks! If I can ever get my MPC working again after trying unsuccessfully to upgrade the firmware, I try your method. I still want to read the “MPC Bible” I bought for it, but have had other studio interests in the past two years since I bought it. As I have done in Logic on my laptop and with the Hapax as well, I will also plan to make a template project on the MPC with all the tracks assigned to a different Hapax Track, so really simple to get going on a song.

Does anyone have a screen shot of the midi settings I should use on MPC to just simply trigger pads from HAPAX? I’ve tried all of the typical settings and followed YouTube tutorials, I even tried the Track page as suggested above, but for some reason I can’t get the definition file I’ve created to talk to MPC One. I’ve tried POLY and DRUM configs to try and make this work.

I’m trying all of the above over DIN connection on midi channel 13, but it only seems to trigger from another HAPAX track that I’m using for my Vermona DRM. I even tried to replicate the CC notes from the Vermona definition file (as opposed to the CC notes in the AKAI manual for each pad) and this works, but the MPC is still listening to the midi from the Vermona track at the same time, so I can’t get it to just listen to the designated HAPAX track I’ve set up.

I’ve spent a few hours on it and no joy. Not sure if this is something to with the global/track/remote setting within the main preference midi menu, but I feel like I’ve tried all variations of this, but again, no joy.

The MPC midi is overly complex for my needs. I’ve not had any issues with any of my other kit and HAPAX. It’s like a DAW I suppose, but I just want the simplest of pad trigger functionality.

I wonder why AKAI doesn’t have a midi implementation chart in the manual - is this because you are supposed to map it manually every time?

Hoping someone can steer me in the right direction.


1 Like

i connect mine via USB (Hapax host, MPC device) and set Hapax MIDI 1 to Track on the MPC. gotta set each MPC track to a particular Hapax MIDI channel, and also set them to Merge

it works by DIN but Hapax isn’t going to show up as a specific device in the MPC MIDI preferences (i forget how MPC designates a generic MIDI In device on the DIN slot). either way my recollection is you just set the input to Track and then assign your Hapax MIDI channel in Program Edit/Track view

1 Like

Thanks very much, I’ll try this out. Cheers!

other thing about triggering pads (as a Drum Program) is to make sure they’re mapped to the note values you’re trying to trigger from Hapax. for me, there appears to be a weird discrepancy between what Hapax considers C0 and how MPC treats C0 – MPC goes all the way down to C-2 and up to C8 or something in its range of pad note values; but Hapax only goes down to C0 as its absolute bottom. so you may need to compensate by mapping the MPC pads a couple octaves higher than you think you should (or vice versa, I don’t have it in front of me to recall which way the gap works)

i generally map all my non-chromatic pads (one shots, vocal samples/chops) all the way down to MPC C-2 because there had been a bug in the firmware that prevented two note values on different tracks from triggering simultaneously, e.g., if you had a kick on pad A1 and mapped to C1 on Track 1, it would choke any other C1 note values on other tracks like plugins. reportedly this bug was fixed in 2.11.7 but i find it a good practice anyway to avoid as much MIDI note overlap if i possiblycan. that said, there is the basic Chromatic mapping option for pads in the Track edit menu, which will start at C1 for pad x1 and go up by half steps for each pad

1 Like

Thanks again, that’s useful to know. I’m going to try a HAPAX poly config and see which notes on the Hapax activate the pads and see if I can reverse engineer the mapping

i found it helpful to put Hapax in Live mode when i’m hunting for an MPC pad to trigger because the grid buttons will trigger a note when the MIDI connection is working – you can just scroll up and down the octaves using the left encoders, top row. mashing grid buttons until you hear an MPC pad trigger


Setting the pad layout to chromatic helps too, at least for my sanity, to just have them go C1, C#1, D1 from the bottom left corner.

I’m still hitting this annoying MPC bug of notes getting clobbered on different channels, I’d love to just set up one type of drum track and use it over and over instead of painstakingly planning out notes that don’t overlap across all my tracks.

1 Like

Good idea! Who’d have thought such a well established tool as an MPC, could be such a pain to use.

I’ve only used it handful of times, as bought it at Christmas, so it could just be that I need to learn how to work with it properly, from the basics to the advanced stuff.

I’ll get the tutorials out!