CV out of the pyramid from a midi keyboard in

Hi everybody,

Is there a way to play the CV out of the pyramid from a midi keyboard connected to the pyramid?
Midi in to CV out.

Thanks.

Oooh, that’s a good question.
I don’t CV (yet), but if I may chime in until those with more experience/knowledge pipe up:

I’d start at first ensuring my MIDI In settings are consistent with what I want to achieve (see “MIDI In”:

Then on a Track I’d use the Track Options to make sure it’s sending out CV (see “Track Options”):

And of course I’d verify that my CV Settings are consistent with how may rig is configured (see “CV/Pedal”):

Personally, I’d probably just do this in Track Mode, ensuring the Track I’ve prepared is selected. Your mileage may vary depening on your Omni/Multitrack settings - season to taste. :skull:

Sorry if you’ve already tried these things.
I imagine you have - did this not work as expected?

Edit to Add: I’d swear when I’ve copy/pasted the anchors were maintained. Crazy.

1 Like

Thanks for your reply.

I can play the CV out from the keys in LIVE mode no problem. I can also play every other gear connected through midi because i can select the midi channels no problem there either. The CV track is apart from the midi channels so no matter what midi channel i put on the keyboard it will only talk to the midi channels on the pyramid.

Hrmmm…even if you’re in Track Mode and the Active Track has CV selected as the Output?
(Honestly, that’s my gut reaction how it should work - but I’m known to be wronger than wrong in most situations)

Is PyraMIDI On or Off?
On MIDI In settings, what do you have for “Assign Note To…”?
What Omni Mode?
MIDI Echo?

Sorry that I can’t be more help. :confused:
I’ve had my modular stuff on order for waaaay to long, but it’s on pandemic lag.
Blech.

:skull:

Track mode is active, CV is selected. Also tried USB + CV (I receive midi via USB).
Pyramidi = Off, I have tried a channel
Assign Note To = Keypad
Omni mode = Multitrack bank a
Midi echo = Stop echo

:grimacing:

I’m assuming you’ve tried many combinations of Settings.
I normally forget how many permutations I’ve tried when I’m in similar quandaries. Apologies if you’ve tried and documented your steps and I’m only suggesting things you’ve already dismissed.

However, the only changes I’d think would be appropriate would be:
Omni Mode: Multitrack Off (So Incoming MIDI is sent to the Active Track)
MIDI Echo: Allow Echo (Because even tho we’re not talking about MIDI Note Data, we are talking about Note Data, and we still want Note Data to go)

Something something MIDI Out and not having MIDI Out + Thru, but I kind of figure first thing is to make sure we can get the data out that way - if it’s possible.

:skull:

on the pyramid the incoming midi does not correspond to a midi output channel (or midi).

even in omni=multitrack mode … the midi channel is mapped to a track number (nothing to do with midi channel)

so assuming you have OMNI = multitrack bank A
if you send on midi channel 16, then track 16 should be with track+channel to CV - this this will output cv/gate.

(as @CreepyPants pointed out, if you set omni=off, then you have to select the track you made track/channel=cv)

if your using eurorack thats all you have to do… as its defaults to v/ovt

the other setting that might in some cases ‘trip you up’ is ‘CV OUT 1V NOTE’ , this defaults to C1=1v , so if you are playing your keyboard in higher octaves so C6, you’ll be above the 5v output of the pyramid…
or depending on how your oscillators is tuned, high notes ~C4-C5 (4-5v) might be playing high frequencies/ or outside your oscillators range.

(you should though be able to see this, if the live pads are playing notes)

in both cases, you can change cv out 1v note, to be more suitable to your needs if required.

Thank you very much for the support guys.

I got it working.

You are clever. :nerd_face:

2 Likes