CV offset in modulation mode, external modulation issues + CV range bug


#1

Hey,
Is there a way to offset the CV once it’s received via Input A, B, C or D ?
I’ve been trying to modulate a CC parameter on an Octatrack via Hermod but I need to offset it.
I have a track set to “modulation” and the CV input is set to “Input A”, I was thinking that setting a step to 0 in “step mode” would act as an offset but it seems to override the CV input and nothing else. The minimum midi value being sent is alway 63.
Thanks.


#2

Hi,

Did you try to transpose it using a scale effect ? Maybe it could do the trick ?


#3

Nevermind, I forgot the scale effect has necesseraly an effect when put in the rig…


#4

Hey, thanks for your reply, that’s an idea I could try, maybe not with the scale effect which might work only for a Note track, I don’t know the module very well yet. Does the Midi effect have a” transpose” setting ? I don’t remember. If it doesn’t exist yet, I guess an Effect dedicated to offset, attuenuators and atenuvertors would be welcome for people using the Hermod as a CV to midi module in certain situations


#5

This is where a track transpose effect or function would be super handy, right?

I’ve been noticing a lot of strange discrepancies between note number, and octave between devices which don’t normally have them. It’s been interesting.
I would love to be able to make track adjustments, or shift things afterward. Keep things together, and clear.

I’ve been recording based on the destination, and then once I’ve captured the performance I want, either adjust the device (module) or step edit the data on the track.

Any chance an attenuator before the input could provide the offset?


#6

Yes, I’m gonna try with an offset/ attenuator before the input. My source is a Pamela’s New Workout (0V to 5V) and the inputs of Hermod are -5V to 5V.
There’s a “CV In Range” in the “CV In Settings”, but it doesn’t seem to have an effect on how the CV in is scaled. “-5V to 5V” or “0V to 5V”, scaled to midi, the minimum is always 63, that could be a bug. And when a modulation step is recorded, the external modulation is totally bypassed. I think we could use an option to change this behavior.

  1. The step is the master and the external modulation is ignored (actual behavior)
  2. The external modulation and the steps are mixed together ( this could be very handy because we could set a variable offset or transposition using the steps menu)
  3. The external modulation is scaled and the steps are ignored

I’ll make further tests with a Maths today and see if the “Cv in range” issue is a real bug or just me not knowing the module enough :slight_smile:


#7

I made further tests with only the internal modulation, an LFO effect in that case. I discovered that changing the “Mod range” in the Midi params effect stops the CV output. Weird. I’m miussing something or it’s a real bug. The “Midi output” still works. If anybody wants to replicate the issue before I send an e-mail to Squarp, these are the steps to reproduce:

Set a track to 1 voice , modulation.
Add an LFO effect to the track, you visualize the CV out using the corresponding LED or an external module.
Go to Midi params and change the mod range Max or min to anything else than -5 , 5V and the CV out freezes.

By the way, it could be cool to have the possibility to stop LFOs when clock or transport stopped.


#8

Hi Elberstein, i can confirm this strange behavior.
And it’s the same if you change the order of your procedure.
If you begin to modify the mod range min to anything other than -5v you can’t obtain any modulation on your output.


#9

Thanks @Patatelemage I will then report the bug to the Squarp team via e-mail


#11

Hey,

This bug still exists in 1.02, here’s how you can replicate it:

Set a track to 1 voice , modulation.
Add an LFO effect to the track, you visualize the CV out using the corresponding LED or an external module.
Go to Midi params and change the mod range Max or min to anything else than -5 , 5V and the CV out will freeze.

The title of this topic is not relevant anymore but this bug was found while looking for something else…


#12

Thanks, it’s reported !