Critical 1.021 bug with MIDI notes sustaining forever


#1

I’m having a problem where MIDI out notes sustain indefinitely if I happen to play the same note via MIDI controller that Hermod is already playing in a sequence.

This video shows the issue with 1.02, but it’s still happening with 1.021 (skip to 1m12s):

Is anyone else seeing this issue? Whenever it happens (and it happens very often), it renders my rack useless until I power cycle it, since Hermod is the core of my system.

I emailed Squarp with a bug report 3 weeks ago and got back “Regarding the MIDI note sustain, I will investigate it ASAP” but I haven’t heard anything from them! :frowning:


#2

I wish hey’d be more propmt to resolve these really annoying and often crippling bugs. :frowning:


#3

Hi cowboy,

Maybe i am wrong, don’t you have a midi loop in your setup? Your keyboard midi out is plugged Hermod’s midi In and Hermod midi out to you keyboard midi in. If you didn’t set the right setting in your synth it will play a note when your press a key and receive almost at the same time a note from midi out telling him to play one more time the same note. One more thing, do you have still the issue if you simply plug synth midi out to Hermod Midi in and Hermod midi Out to your synth midi in ?

Thanks,


#4

I don’t have a MIDI loop in my setup, because local is off. However, here’s another video to show you the issue. In it, I use a totally separate controller from sound module, so MIDI echoing shouldn’t be a problem.

Here are the exact steps to reproduce this problem:

Physical connections:
MIDI Controller out (eg. Yamaha S90ES) -> Hermod midi in
Hermod midi out -> MIDI Sound Module in (eg. Yamaha MX61)

(You can also use one keyboard as Controller + Sound Module, as long as you have local echo disabled)

  1. Power cycle Hermod so it’s at default settings
  2. Set Track 1 Effect 2 to MIDI OUTPUT
  3. Play the Controller, you should hear the Sound Module
  4. Start Hermod Record mode
  5. Record a few chords in a loop
  6. Disable Hermod Record mode, but let it keep looping
  7. While the chords are playing, play a note on the Controller that overlaps one of the playing chord notes
  8. Hear that note sustain forever! (this is very bad)
  9. Stop Hermod
  10. Play more notes on the Controller, the note that was sustaining forever will continue to sustain forever when played, all other notes will sustain normally
  11. Power cycle the Sound Module. Once done, notes should sustain normally
  12. Start Hermod playing and repeat steps 7-12 until you want to throw Hermod out a window :frowning:

Can anyone else please confirm this problem? It seems like a really weird problem to have, and I want to make sure it isn’t just me!


Can anyone with a Yamaha MIDI keyboard try to reproduce this issue?
Compatibility with Yamaha YDP
#5

Hi cowboy,

We tried several times the exact same procedure with a Roland Alphajuno and a Waldorf Blofeld. No stuck note. It probably means that the Yamaha S90ES has a special midi implementation and maybe we don’t handle it properly. Do you have other controller to try instead of this one ?

Thanks a lot for your help.


#6

Erratic behavior happens on my Yamaha S90ES, my Yamaha MX61, and my Instruo QPQ quantizer.

However, I just quickly tried Hermod with a MicroKORG, and there were no problems. Is it possible that Yamaha does something different? Is there any way you can try Hermod with a Yamaha?

As for the QPQ, I have no idea what’s going on. Maybe it’s similar to the Yamaha.

I just found this https://www.midi.org/forum/228-writing-midi-software-send-note-off,-or-zero-velocity-note-on

"From what I can find out online, most modern MIDI equipment (keyboards, controllers) sends Note On messages with a velocity of 0 to end a note, rather than Note Off messages as per the spec. IIUC this is to make it easier to send a complete sequence of notes using running status. "

“A receiver must be capable of recognizing either method of turning off a note, and should treat them identically.”

Is it possible that this is what’s going on? Is there any way you could create a test build of the app code that tries to do it the other way than how you have it, so I can see if that’s the problem here? Anything you can suggest would be helpful. I don’t have this problem with any other MIDI sequencer! (But of course, nothing else is quite like Hermod, either)


Can anyone with a Yamaha MIDI keyboard try to reproduce this issue?
Compatibility with Yamaha YDP
#7

Someone else reports the same problem in this thread: Compatibility with Yamaha YDP


#8

…I was able to replicate your result, but would not call it a “problem” because it only appears in irrelevant situations. Also, the fix is easy: Just change transmission channel of piano or out channel in midi out effect on Hermod. This also show that what you are observing might not be a Hermod bug, but a general Midi issue.


#9

I think your comment is correct: I was able to replicate the “problem” on a Yamaha YDP piano with a USB connection. The “problem” is gone as soon as I change the Midi channel in the MIDI OUT effect of the notes played by Hermod, for example. Alternatively, one can change the MIDI transmit channel on the piano.


#10

You say it’s irrelevant, but it happens to me every time I play, because I use the Hermod as a live looper. To me, it’s extremely relevant!


#11

You can still use Hermod as a live looper, just adjust the MIDI settings as I have described it in various postings (the relevant parameters are MIDI receive and transmit on your voice, and the channel settings in Hermod’s Settings menu as well as the channel in Hermod’s Midi Out effect).

What Squarp could do is program the famous “MIDI Panic Button”, i.e. fire off an “all notes off” message when for example long-pressing the play button (i.e. press it for more than 2 seconds). Hanging notes can be the result of a lot of factors.

This was my last posing related to this topic.


#12

In case anyone is interested, this bug is still happening with the latest hermod 1.21 firmware. I reported it to support, again, and hopefully I’ll get an answer this time.

To reiterate, it’s literally this simple: If I happen to play the same note on the MIDI controller that is already recorded in the track, the note becomes stuck forever and ruins everything. The only way to fix it is to clear the loop, use some kind of MIDI panic button on any affected device, then re-record the loop.

It even happened to me the other day when I was playing in front of a room full of people, which totally killed my flow. See this video. Right when I finish playing the organ part here, one note gets stuck, which I then have to try to fix (by clearing the steps, doing a MIDI panic, and then re-recording) and then when I do, it happens AGAIN.

The hermod software seems to have some kind of note on/off state problem.


#13

Painfull to watch, hope this can be fixed quickly :frowning:


#14

FYI, I forgot to post back in April, but in case anyone was following this issue, it was fixed in hermodOS V1.3!