Create Multiple Tracks With Same MIDI Channel

Is it possible to create multiple tracks with different MIDI notes without going into Pattern Mode?

For example, if I have Track 5 (MIDI CH: 4B) dedicated to five bars of notes and then I want to create Track 6 (MIDI CH: 4B) to play five bars of different notes. Is that possible if I mute Track 5?

If i understand your question correctly: yes.
You can have Track 5 and Track 6 with Note and/or CC events going to the same Pyramid Port & MIDI Channel destination. You can play both at the same time, or Mute one or both.

Example: i have 3 Tracks that go to the same Pyramid Port and MIDI Channel, and often the same note(s) for “Kicks” and I turn on and/or let voice at will/by control.

And I also use Patterns, but in a different context.

It’s weird. I’ll create one track with notes and mute it. As soon as I create a second track with the same port and channel configurations, the muted track will start playing back.

How are you “creating” the second Track?
Can you post a Step by Step or video?

Sure.

  1. Select Track (Example: Track 1)
  2. Assign MIDI Channel (Example: CH 1A)
  3. Go to Live Mode
  4. Record Pattern
  5. Confirm playback
  6. Go Back to Track Mode
  7. Mute Track 1
  8. Select Track (Example: Track 2)
  9. Assign MIDI Channel (Example: CH 1A)
  10. Go to Live Mode
  11. Record Pattern
  12. While Recording Track 2, Track 1 unmutes itself and plays back Track 1’s pattern

Okay. Thanks.
Obvs it doesnt do that on mine, so let’s figure out what’s different.

Are you using Hard Record?
Do you have Save Mute States on or off?

I’m spinning gears, but if something else pops into my head I’ll pop on here and post. Perhaps someone smart and experienced might chime in until then.

You’re able to record one part on a track and record another part on another track while applying it to the same MIDI Channel? I’ll keep digging.

No. I haven’t really used Hard Record yet.

I haven’t changed the Mute States since I have received the Pyramid, so I think that function is currently on. I am going by what the user manual states.

Yeah. Thats a regular thing I do.

Okay. I feel like I must be missing something in regards to a setting or a feature.

Yeah, sorry i couldnt be more help.
If i dont use a feature or setting I tend to forget what it does, so if there’s some connected setting Im overlooking, it’s just my ignorance.

I thought it might be in a Track Automation, because I accidentally record CC msgs that end up back on my Pyramid and enable/disable Tracks when Im not paying attention or Im too baked. But i forgot that’s because i set up my rig really weird.

I find that when Im unfamiliar with something, i misread the screens or button combos. Youre very clear and seem quite savvy, so I doubt it’s that.

I appreciate the help. Thanks so much for taking the time. I think the way around this is to apply patterns to each of my tracks. At least from my understanding, this will allow me to compose sequences into songs.

When does the track mute/unmute, while playing notes on MIDI controller? Maybe PYRAMIDI is enabled?

I have all Roland boutiques and use the 25 keyboard controller that accompany each boutique. It happens when I play the keyboard. Also Pyramidi is turned off.

Here is a video I made to present the issue.
https://youtu.be/uRgEzIkfvbw

I was able to sort out the problem I had. I can’t say if this is a solution for everyone or for just my situation. I had to turn OMNI-MODE OFF in the MIDI IN SETTINGS. It has since allowed me to create multiple tracks from the same midi channel.

1 Like

Thanks for posting your solution and Im so very sorry that I overlooked suggesting anything about Omni Mode.

I have never found an actual use for Omni Mode in any MIDI setup Ive worked with so it’s always been off my radar as a potential problem area or as a troubleshooting tool.

I live life Omni Off.
Always.

Glad you figured it out!