Clock out is unstable?

I have tried syncing an LXR 2 as well as a Novation Peak to the Hapax through Midi. I believe all settings are correct, yet starting and stopping the sequencer randomly causes the slaved machine to misread the tempo and start slightly out of time. How can I get a reliable clock out of Hapax? Thanks!

I’m not sure if this is the cause of your issue, but just to try and offer something:

Hapax has the option to send midi clock only when playing, or to keep sending clock also when stopped. This is separate option from Transport control. It’s in the general menu I believe. You could try setting it to continue clock during pauze/stops, and see if it helps. Perhaps that can cause the issue?

1 Like

i wouldn’t over judge the slight tempo variations on the display … do you find the variation in the output of the respective synth? I guess no.

1 Like

I will try the suggestion, I was not aware of that setting. And yes I certainly do hear the sync drift from the devices.

@LessTalkMoreDisco Looks like that did the trick, all locked as snug as a bug in the rug now. Much appreciated!


Awesome, happy that I could help

1 Like

The Peak has a weird thing that when it stops receiving clock, it defaults to its internal clock which is probably at a different bpm (IMO it should automatically adjust its internal clock to the last received clock bpm, but it doesn’t).

This is probably the cause of your issue with syncing the Peak, because it will need a little time to adjust to the new bpm when it receives clock again.

When my mpc live follows hapax midi clock the samples sound bad from the clock moving.
I cant tell if is hapax or mpc is the issue.
But definitely hear some movement

@Maarten it’s not weird, Peak default Clock Source mode is ‘auto’ so it will return to internal if no external clock is present. Quite a common default. It can be changed to external only or other options.

But it would be better that its internal clock would adapt its bpm to an external clock when in Auto mode.

I agree with this… if you are going to auto switch, then at least use the ‘last bpm’ as the starting point.

getting back to the Hapax…

Ive send a feature request recently in this area… its actually quite simple.

so currently, the Hapax with an external clock will be updating the BPM.
all Ive asked is that you can still press play (start the transport) even if the clock is set to external.
this will pretty much give an auto mode, if you set the clock to external.
i.e. its internal clock/transport ‘overrides’ the external setting.

background: the reason I need this is I usually slave the Hapax to Ableton’s clock, so Hapax is set to external - but whilst patching my eurorack, I’ll often just want to work standalone… (without Live).
currently, to do this, I need to switch to internal clock, then remember (!) to switch it back to external when done… ok, first world problems… but still :wink:

anyway, my main point was… Squarp did recognise the ‘issue’.
so if you have some ideas how you would like it to work , then send in feature requests via the Contact Form, and perhaps they will make it in.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.