Changing patterns with both PC and CC issue?

Anyone have patterns that are both configured with new PC and CC values (automation) and is changing between them? I’ve been experimenting with this and seems like only either PC or CC works at the same time?
I am monitoring the midi messages sent with the 2nd+live button and I can see that both PC and CC is sent to my synth upon pattern change but I have a feeling it can’t handle both being sent at the same instance.
I tried it with 4 different Roland Boutiques and a Korg Minilogue. PC on it’s own is fine and CC on it’s own is fine. Maybe it’s a limitation of my synths rather than the sequencers’ timing of events?

Hi Donk,
I am able to send automated CC and PC data of one pattern to my synhs, e.g. Minilogue XD.

I would assume, if the midi monitor shows both data (CC and PC) on midi out, the problem is post HAPAX in Your midi chain.


That’s a good point, I’ll have to test the midi straight from Hapax. I have Faderfox and a large midi thru box in the chain that might be interfering.

But just to confirm, do have you have different patterns on your Minilogue XD track that change both PC and CC when you switch between them? And no problems?

I can send PC and CC from one pattern, that’s fine. The problem is when I have other patterns on the same track with different PC and CC and I’m switching between them. In my case the CC seems to get lost during the pattern switch.

Just wondering if somebody else is having this issue or of this is a known issue with synths (pc/cc sent too quickly together for the synth to receive).

Let me describe more in detail so You can say whether I got You right:
Track 4 on my Hapax sends midi out to my Minilogue.
For testing purposes: pattern 1 on this track got two 8 step notes on 1 and 9.
One step in front of each note I added PC messages in autom mode at the first lane, PC 1 and PC 2.
At the second lane I added cc 43 (filter cutoff on Minilogue) with numerous data along the two notes.
Then I copied the pattern to pattern 2 on track 4.
I changed the notes, the PC an CC to hear some differences.
If I now play back and toggle between the two patterns all PC and CC commands are recognized as expected.

I hope that helps. Let me know if I should change something for testing.


Thanks, I connected the midi straight from Hapax to my Minilogue XD and followed your steps and still wasn’t able to get it working. I must be doing something wrong. Didn’t have too much time last night to test things, I will try again tonight from scratch following your steps.
I might post a video, another pair of eyes might spot some simple mistake I’m doing.

Assuming You are aware of the midi settings on the minilogue, but typical traps woud be:

Be sure the minilogue receives data:
“midi rx prog chg on” and
“midi rx cc on”.

Be sure to avoid midi loops, maybe try:
“midi tx prog chg off” and
“midi tx cc off”.
It may help, if You describe a little more in detail what’s the behavior of the minilogue. If I got You right the minilogue still stops processing incoming cc data or pc data if You select another pattern on Hapax which is still sending cc and pc?

1 Like

Thanks for all your suggestions, I checked the Minilogue settings and rx pc is ON and rx cc is ON. I don’t have any midi coming out of the Minilogue so tx shouldn’t be a problem.

I recorded a video hopefully demonstrating my problem.

I made two patterns in track one. Both with their own PC and CC (automation) on my Minilogue XD.

The presets are by default high frequency and the automated CC should filter them down to sounding softer. I made a thumbs up/down gesture if the PC/CC was working correctly.

I had the midi monitor running and the PC/CC are being sent according that.

Hopefully this makes sense :slight_smile: donk hapax pc/cc test - YouTube

Hi Donk,

Ok, now I see. :bulb: :trumpet: :notes:

Now I’m able to confirm Your experience.
You send cc and pc at almost the same time.
But the minilogue processes the pc command not fast enough!
It’s even worse sending note data. I have to skip the first 1/16 note following a pc command.
Try to set the note of Your test pattern at the beginning of the bar and it will skip the first loop.

So try to set the cc command at least one 1/48 step following the pc command and we will see …

I noticed that Hapax don’t send cc data of the following pattern if the pattern before has the same value of a certain cc number. :grimacing:
Even if there are pc commands in between, Hapax doesn’t send the same cc value twice. It waits for a value to change until it sends data of a certain cc number.

This means for Your testing purposes if You would set the same cc value on both patterns You wouldn’t get an cc command on the minilogue anyway and the pc change would reset the cutoff value.
I will send a feature request for re-sending cc data on pattern change.


haha, thank you at least I’m not crazy :+1:

Yes I suspected that sending messages too fast was a problem. It also happens with other synths (I’ve tried JP-08, SH-01A, SE-02, JU-06 :musical_keyboard:)

Yes, to test this I disabled the first few steps of automation on Hapax but according to midi monitor it was still sent immediately on pattern change? Is there a way to send CC just on the 3rd step for example?

I tried sending a different value on the first step to force Hapax to send CC on the second step and that actually seemed like a promising workaround but the downside is that the CC is reset every pattern start which kills all live CC tweaking :frowning: (live tweaking is very important to me)

Exactly, that’s my experience as well. But I actually do like that Hapax doesn’t spam CC needlessly.

Exactly, that’s my experience as well.

Thank you! I thought Hapax was already doing that so I was confused and therefore made this post.

But thinking ahead, If Hapax sends CC correctly on pattern change, won’t we still have the problem of sending PC/CC too quickly?
Would synths need a few milliseconds of delay between messages?

And now I’m actually thinking if ‘automation default’ values should be used for this? The manual (section 10.6) says:

"Default values are useful to send fixed values, without the need of creating any
automation event. It also allows to reset a parameter upon a pattern change."

But as far as I can tell, the automation default values are per track! Not per pattern. Could somebody else confirm this behavior?

So I’m now thinking if automation default values were actually per pattern (sent on pattern change like you suggested) and with a slight delay to allow the synth time to process the messages it would solve all these problems?

Again I hope I’m not too deep down this rabbit hole :crazy_face: and this makes sense to somebody other than myself.

I believe in the midi monitor depending the order of messages not the exact timing. :wink:
Even if there is a break between the pc and cc command, as long there is no other midi command the midi monitor will show cc straight behind pc.
I got stable results by zooming in step mode to 1/48 and setting the leading cc command on the second column.

And this is the disadvantage if it works as we like to! :grimacing: :sweat_smile:
If we want to change a pattern which includes cc commands while we are live CC tweaking the same cc number we are fighting against the automation data. :nerd_face: :slightly_frowning_face:

In Your case, if You need cc data to tweak the sound of a appearing preset on the minilogue I would recommend to spend another preset with this particular sound instead.
I know, not as handsome. :slightly_frowning_face:

Yes and Yes. Therefore I skipped the first cc automation column in step mode as I mentioned. :sunglasses:

But only if the previous pattern sent a different value!
So, after the pc message You have to set a cc command (or live CC tweaking!) in any case to update the synth sound.
(BTW You are able to set pc commands as an automation lane.
Thats what I did in my first test. Assuming timing issues I set the pc commands at the end of the leading pattern :nerd_face:
I guess not very helpful for You. :upside_down_face:)


What I learned so far:

  1. It would be great if Hapax would update the ASSIGN values with automation values.
  2. It’s necessary to note the context of automation and live tweaking in the workflow to not fight against each other.
1 Like

Very interesting yes, I’m coming from DAW world so some of this new to me. I at least have some workarounds. I will most likely spend a few preset slots on my synths to save the patches how I want them.
Sometimes I could see myself using the automation tricks like you suggested. Maybe even use a dedicated ‘set up’ pattern, just setting the parameters how I want them with no notes. Lots of possibilities. Thanks a lot for your insights.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.