Bugs with MIDI clock and CV-controlled recording


#1

I just came across a few more bugs (that I have reported via email). Has anyone else seen these issues?

  1. When Hermod is first starting up, it outputs a MIDI clock signal, which causes any modules listening to the MIDI clock to start playing. If I disconnect the Hermod MIDI output, none of the connected MIDI modules auto-start playing, so I assume Hermod is causing this behavior. Also, the MIDI clock signal stops once the default Hermod preset loads, which causes any modules listening to the MIDI clock to stop playing. Connected MIDI modules should not start playing while Hermod is starting up.

  2. When Hermod is set to use its internal clock and Play is pressed, or when it’s set to use an external clock, and receives one, it starts playing, and any modules listening to the MIDI clock start playing as well, as I’d expect. However, when the internal / external clock are stopped, none of the connected MIDI modules stop. If I go to Seq -> Project -> Load (I don’t have to actually load a project), the connected MIDI modules stop playing. Connected MIDI modules should automatically stop playing as soon as the internal or external clock is stopped.

  3. If I go to “Clock In+Out” and set “CV Transport” to any of the “Rec” settings like “CV Rec A”, a gate into that Hermod input causes Rec to be enabled while the gate is high, as I’d expect. However, repeated gate inputs can very easily cause Hermod playback to get out of sync, which makes CV-controlled recording unreliable. If I stop and restart Hermod, playback sync is reset and works again (Until I try to CV-controlled record again). Triggering recording via CV shouldn’t cause Hermod to lose sync.