Bug? USB sync thing


#1

Hi! Whenever I try to switch the USB line to On inside the “Misc” category I get this:


I want to run it as a master through the Bomebox and it seems I got stuck on that error and on the Bomebox not seeing the Pyramid. Like at all.
At the same time it sees everything else.
Help me, please.


#2

Narrowed it down - it has something to do with sync start stop.


#3

I’m not at all sure if this is helpful,
but when I first got the pyramid i caused a lot of errors on early betas due to massive midi loops.
Due to the port config on the Bome box it’s pretty easy to inadvertently create a midi loop… this does cause some weird behaviour with the Pyramid.


#4

Thanks! Will definitely look into this in the morning.
But in my extensive experience of midi looping the Pyramid and Digitakt(:sweat_smile:), it never showed a message like this one - usually it just freezes. So that’s a new one for me.:smile:


#5

Yeah, it’s definitely indicative of a crash / error… email the ever helpful Jean in support at Squarp and he’ll work through resolving for you (in my experience)


#6

I just did that - posted a support ticket.
Thank you for your response!


#7

I’ve got the same issue when I want to send midi via USB.

I’ve tried the MIDI over USB by connecting it to my AKAI MP Live and also another try with my iConnectivity MIO10 MIDI interface.

Both without result, crashes each time on sending MIDI data (notes or clock…).

What was the solution?

Thanks!

L


#8

edit:
Your error log seems a bit different.
Try writing to support if switching the lines and messing with settings won’t work for you. Maybe your problem has some other reasons.

I changed the USB line and it suddenly just started to work. I don’t think I did anything else.
Maybe I experimented with USB settings in “IN”, “OUT” and “MISC” tabs, but I can’t really remember where I started and what I changed.
In the end I got myself a Pyramid that works fine with both USB and MIDI in/out sync simultaneously. One of the Out ports has “turbo midi” thing on.

Sorry for not being of much help. :frowning:

P. S.
Tech support seemed as puzzled as I was with this bug/error.

P. P. S.
Do not forget to turn the USB “On” in misc. For a couple of months I didn’t know about this thing and was trying to connect my Pyramid to Live to no success. :sweat_smile:


#9

well,

Even if only “USB on” is selected, and all other USB functionallity (sync etc) is set to off, the Pyramid crashes after I play back notes (inserted in STEP mode) via a USB channel.

I used a brand new cable that comes from another musical USB device, so it should work fine with that cable.

I guess it might be a MIDI-loop thing? But I think in the iCONFIG software of my MIDI interface, the output of USB host jack isn’t forwarded to it’s input to prevent MIDI loopback issues, so I’m not seeing where the loop can be caused…

Hope SQUARP or other Pyramidians can help me out…

thanks


#10

Email support.
And check the MIDI IN monitor on the Pyramid to see if there is a loop.


#11

I even can’t find Pyramid on my Mac when connected.

The unit receives power, but I can’t find it in “MIDI STUDIO” / any DAW or MIDI MONITOR…

I’m in touch with the dev team also.


#12

after saving “USB ON” to default settings, the unit doesn’t crash anymore,
but it also doesn’t send data (clock or notes) via USB, although the ICON on top of the screen indicates signals are being send via USB out…

Still the device doesn’t get recognized on my laptop (macbook pro 2011) as well when I connect it directly to it…

bizar


#13

I said Pyramid MIDI monitor. There is one onboard :wink:


#14

Yes Joosep, I know what that already, but thanks :wink:

I tried to use that onboard monitor also, but because pyramid crashed always immediately from the moment I have send USB data from it, that onboard MIDI monitor could NOT be used.

Since my previous post update the pyramid didn’t crash anymore. The icon above the screen shows there is output on the USB now, and yes I see it in the onboard monitor also.

Though, the MIDI data send via USB isn’t yet received in my other devices (on my laptop I use the MIDI monitor to check what I am receiving + what decices are recognized and connected well).

Strange enough pyramid is’nt showing up as a device on my computer when connected via USB. I guess that should be the case, as other USB MIDI devices show up in MIDI Monitor + in the list of available MIDI devices in a DAW.


#15

I really don’t have a clue how I did it, really not, but things work like they should now!

The Pyramid finally showed up in my MIDI devices list / DAW on my computer, sending notes out via USB successfully.

Also, when I connect the Pyramid to the USB HOST jack of my MIO10 interface (to use Pyramid without a computer), I finally can send notes out from Pyramid USB to the other DIN sockets of my MIO10 interface.

Connecting the Pyramid to the MPC live is also working fine now.

No crashes anymore when using USB, no problems sending out MIDI data via USB anymore.

Nice!

Seems to me it was some kind of a weird Pyramid / USB bug.

Hope things stay fine now…

Thanks for trying to help!

18