[Bug?] Double-tap Glide mode not working


#1

On the Pyramid, I just tried changing the setting for the “double-tap” shortcut in step mode from Velocity to Glide, and it doesn’t seem to be functioning properly. I will double tap in a note that precedes another, but instead of it’s duration being matched so that it overlaps with the following note, it is given a duration of “2”, no matter how far away the following note is. Weirder still, if I’m in Display mode for Step mode, the note I double-tap in is not shown as having a duration of 2, but instead is shown as the same duration as all the other notes. If I change the duration manually to 2, it looks different then it did when I tapped it in. This surely is not how the glide mode is intended to function, right?


#2

I got the same problem. Hope they fix it on the version 3…


#3

I hope you mean the next OS update, rather than “mk3” hardware revision that people keep talking about. This is a software problem and definitely doesn’t require a hardware update. I am not sure which you mean but I’m just clarifying in case someone misunderstands.


#4

Id assume we all mean OS 3, given there is no mk3 hardware - user chit chat, has little to do with what Squarp may or may not release :wink:

Id say given Squarp are only just releasing Hermod, they are currently focused on eurorack, and Id expect them to wait to see how well that sells, before they decide if the future is more standalone products (like Pyramid) or to focus on modular (like Hermod) … or perhaps even a hybrid.


#5

I agree.
that’s probably what they will do…
I wish them to sell a lot of Hermod units
but personally I’d prefer they focus on standalone MIDI sequencer market… :wink:


#6

thanks i didn’t know about the doubletap feature


#7

It works only if the double-tap note is placed on the step just before the other note.
For eg, add a note on the STEP 04, and add a note with a double tap on the step 03


#8

Double tap when set to glide does not seem to be doing anything here either, I’m on 2.9921


#9

Just tried v2.9922 and still same.


#10

Edit - no this was wrong, still not working though.


#11

@squarpadmin I see - that seems rather limited. Is there not a way for this to work with notes more or less than a note apart? There are obviously other situations where a glide might be nice (e.g. for longer notes, or more rapid glides)? Maybe the legato function could just add a few ppqn beyond the next note to the note you doubletap, regardless of length?

Either way, if this cannot be fixed, the manual should be more clear about the legato functionality to avoid confusion.