Best way to copy everything to a new project?

I’m guessing that my current current Project is semi corrupted because I keep getting this error message frequently.

My Pyramid is slaved to my Octatrack. The only “symptoms” I’ve noticed, other that this pop-up, is that every time I press play, some of my tracks are “updated” with random LSB and MSB values, even though they do not share the same midi channels with anything on the Octa.

So I’m guessing I should start a new project. But how do I transfer my work/tracks to a new project in the easiest manner? I would hate it if I would need to start fresh because I have put in a lot of hours into this…


Im assuming this is on latest firmware.

Id say first thing is to report to Squarp via contact form as they may be able to help recover your project… and determine the issue.
we don’t really have enough info on that screen to determine the exact cause.

in the meantime here is what Id do (assuming time/patience)

first backup the project … before any changes ! (on to your computer)

then you have a few options :

a) look in backup folder, and try to use that project.
each time you save a backup is made, perhaps the last backup was ok.

b) slowly try removing things you ‘guess’ might be causing the issues.
e.g. you mentioned random LSB, MSB
but also things like FX or automation lanes, or particular patterns on tracks

after each change see if it makes a difference.

once you have found something that ‘fixes’ it, you can go back to your original project (remember you backed it up :wink: ) … and see if just ‘removing’ that one thing, is enough.

but this could be a bit laborious , as its trial n’ error… or you might be lucky, and find the fix on first try… but you’ll never know :frowning:

c) start a new project and copy over the midi files from this project
this way you have notes/automation etc… but you’ll have to go setup things like fx/track lengths etc.
so really depends how much effort you spent in programming notes vs the ‘project settings’

d) advanced - I published some details on the forum about the structure of the project files.
SO , you could look thru them to see if there is something ‘odd’.
BUT honestly, this is might be a lot of effort… and is also not guaranteed to find the issue.

but hopefully Squarp might be able to help… perhaps they have tools to look at project files… they also have access to the firmware code so will know what is (basically) causing the issue.

1 Like

Thanks for the thorough answer. Luckily it’s not a really big project, so I’ll go the “manual midi file import” route.

Just a bit worrying that this was so easy to stumble across. It’s my first project I’ve been working on for a couple of months, and already a bug/broken project…
I thought I ditched my daw workflow to get rid of these kinds of issues… Sigh…

1 Like

sounds unlucky…

Id still report it to squarp, as hopefully it might point them in the direction of a bug that could be fixed in a firmware release.

similarly, if you see it again, and determine what action causes it that could be helpful too.

we all uses these things differently, so sometimes a certain set of actions we get into the habit of , but others dnt use… can cause issues for some, but others don’t see it.

I have reported it :+1:

I tried the manual midi import to new project.

  1. I first created a new project and saved it.
  2. I then opened the SD card on my computer and copied only the midi files to the new project folder.
  3. Back in the Pyramid I had to reorganize what pattern belonged to what sequence etc.

The sad part is that the bug (or a new one) showed up again while in Sequence mode and when switching between patterns on one of my tracks…

So does that mean one of my midi files is corrupted? How would I troubleshoot that in that case?
Or can my Pyramid OS be corrupted? I still had track settings saved when I started the new project…

I’d add one midii file at a time and see which one causes crash

Sigh… I will do that. Haven’t heard back from Squarp in a couple of weeks now. They’re probably fully occupied wwith Hapax.

Anyone can recommend another sequencer? Deluge the only close alternative?

they probably are busy… there’s quite alot involved in a product launch, and of course inevitable preparation of the release firmware.

Id have a look at the data… the pyramid is completely stable.
you’ll find lots us have used it for years without issues, so its a matter of getting to the bottom of whats causing your issue.

Try re-downloading & reinstalling the os maybe something got messed up the first time & then do everything thetechnobear suggested, also see if this error happens with other projects. If none of this work then do what the Pyramid told u & get in contact with Squarp. Good luck!

Do you understand any of what the bug screen says? It seems “Track C” is always present in my case… Is Track C the same as Track 3, or are they totally unrelated backend?

What is 1160 refering to?

we have no info on the actions codes.

track.c is going to the the source code , 1160 could be line number - so no use to us with the source code :wink:

track note patt 2… your guess is as good as mine :slight_smile:
Id guess its something to do with a NOTE event, on pattern 2?

perhaps load it into a DAW and look to see if there is anything odd?
one guess (and its only that) , might be something like a note number thats invalid ( eg. outside range 0…127) , or a note on without a note off?

that kind of thing - but its all a guess.
you have to dig into it and see what’s happening

one other thing that MIGHT work is (if you find the ‘dodgy’ midi file) is load it into a daw, and then save it again.
(as daw may ‘strip’ invalid data when it loads it)

BUT if you are using patterns becareful , because a lot of daws do not support patterns well… and many have had issues with importing/exporting midi files to /from daw<->pyramid.

(see my previous posts on this… as Ive gone into details about what worked for me, and not)

All right! Well now I know what my weekend looks like :sweat_smile:

Now that you mention it, yesterday when I tried to import a track into my Daw, it looked like there could be double /overlapping notes on some tracks. As in one note that was Note On for 8 bars, and in between there was more short Note On on the same note, but on top of the long note. Perhaps that could be something to investigate…

1 Like

i don’t know how much stuff you have to ‘salvage’

but the other route might be import into a daw, and then just ‘play/record’ it back into the Pyramid.
(you could use multi track reording / omni mode to help)

so basically bring it into a daw, find anything that looks ‘dodgy’ , and then record into pyramid from daw.
(Id test regularly, don’t spend hours doing this, only to find it crashes again :slight_smile: )

it might be ‘faster’ than messing about doing import/export and pulling your hair out with that.

of course, if you find these dodgy notes… then Id be looking around your studio setup to find out the cause (midi feedback ?) , so it doesn’t trip you over in the future !

So I did the “Record from daw to Pyramid”.
I have also disconnected the input to my Pyramid so that I can add one thing at a time so I know when the bug shows up again.
So far the bug is not present. But i’ll add more information to the tracks (names, defintion files, program changes etc.) this evening to see what could trigger the bug again.

One thing I have stumbled across is that I can’t remove residue Note and CC information from one of the tracks. The track is empty, but still the Track page shows that there should be Note and CC information present on that track… Is that a known bug or could that be related to “my bug” in this thread?

the project files do not contain note information… all those ‘events’ are stored in midi files.
so perhaps you have ‘rogue’ midi file lying around.

(hard to know as its all rather depending on exactly what you did … rather than what I think you did :wink: )

as discussed above, Im ‘hopeful’ that what you’re seeing is that there was some invalid midi data recorded on the pyramid originally, and that importing into the daw has cleaned that up.

but again, when you start adding names/instrument defs, check they don’t contain anything dodgy/suspicious … e.g. perhaps avoid special characters, make sure the instrument def is valid.

my suspicion is the pyramid was crashing due to some invalid data.
so the CAUSE is invalid data, the EFFECT is the crash
so, YES, it should catch that invalid data gracefully - thats the bug!
but something else is the CAUSE of the invalid data.

(potentially, why it tripped you up, but not others… since you need that cause to invoke the issue)

feels. :sweat_smile:

1 Like

Did u ever figure out what happen?

Are you asking me? You replied to Technobear.

Im my case I unfortunately did not find the root cause… As it seems now I have at least managed to get rid of the bug by recording the midi data into my Daw, and from there record it back to the Pyramid (did som cleaning of suspicious double notes here and there…), one track at a time… There was nothing obvious there.

I suspect that I perhaps had a midi loop when just starting out with the infected project, and that something got recorded at that time into the project. The bug only showed up a couple of months into working with the same project though… So a bit scary going forward.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.