Assign CV/GATE Input, NO display pops up

Hi there,
I have a problem when trying to assign a CV or Gate input, the assign manager display never appears.
I want to use the 0-coast to control some effect parameters.

When I plug a jack in whatever input holding the ASSIGN button nothing happens.
In the Analog IN Info window seems like the voltage is arriving ok, also the little cv sign is there in the screen.
Am I missing something?
(using PyraOS version 3.23)


…sorry if it was mentioned in another post before,the closest I’ve found is an old post from @KidYoshi (How do I control an effect via CV In?) but I think this is not my case, it doesn’t appears the IHM_LOOP bug wich I think it was fixed some firmwares before.

Yeah that bug was fixed. But, I’ve never gotten cv in to work even though it is detected like you describe.

I reported it to squarp and they said it needed to be sent in for repair. I never got round to it due to cost.

1 Like

i think you can only assign CV (not gate - but perhaps Im wrong)

you need to hold the assign button down for about 1-2 seconds (?) , then if it detects voltages changes (?) it pops up - I usually use an lfo.

the fact that you see voltage on the info tab would seem to indicate it should work!?

not really related,
but one thing that caught me out, was I had a cable connected to the pedal input, that was not plugged into the pedal (because pedal is on batteries, and when cable is plugged in it turns on) - this caused spurious signals on the CV input - I guess because the cable was not grounded.

Every once in a while I try everything again but never works…
Looks like @KidYoshi’s problem, like it doesn’t detect when a cable is inputed or something ,even though the Analog In info tab looks ok and the voltage is passing thru.

But if I’m not the only one having this problem maybe would be nice to know why this happened…
The other Assign stuff works nice.

Never tried the pedal input,I’ll check it out.

The manual says:
You can assign the two analog stereo jack inputs (CV input and GATE input) to control in real-time CC messages and effect parameters.
So CV and Gate should work.

Anyway, first time I can’t solve a doubt digging in this forum…but who knows.

thanks for the answers.

perhaps you can use gate - ive only ever used the CV input (which is stereo, so you get 2 if needed)

does CV/GATE work if you use it for note input?

if you can correctly see the voltages moving on the info screen, cannot see its a hardware issue.

are you able to get midi CC assign to work?

what hardware revision of the pramid do you use?
I own a MKI for some time now and i had a similar issue.
Same thing, CV / Gate values can be seen with the Info window but no assign manager when plugging the cable in.
Thing is, when plugging in the cable, the tip hits an additional contact inside the plug, which is then used for triggering the assign menu. If something is wrong with this contact, no assign menu will pop up.
I pinned it down to this hardware issue myself and had to replace the SMD-plugs… works flawless again since.
Maybe its the same issue on your unit, in this case you should contact Squarp for a (hopefully easier) solution?!

1 Like

@thetechnobear,CV/GATE In works fine, also CC midi assing and voltages Info so this seems to look more like the issue @konrad is explaining.
(I own a MKII model btw)
I think I’ll contact Squarp…and hope for this easier solution.

Maybe the thing that remains to be solved is WHY? it’s just bad luck in the fabrication process or maybe something I did caused this? hope this could help other Pyramid owners.

1 Like

yeah, post to

also, if you have no cable plugged in, are the analog in showing off, or a small fluctuating voltage?
(again mention this when you contact them)

Ive also an idea about how this might work differently that I’ll run past squarp.

I’ll do so,thanks.

With no cable plugged there’s a little trembling 0-10mV on gate inputs (mostly in gate2), don’t know if this is relevant.CV inputs stay at 0mV.

1 Like

Do they say 0mV or OFF?

Interestingly, I played a bit more - and occasionally found I had similar issues …
Sometimes mine say off, at other times it has a small fluctuating voltage.
( my gates never appear to say off!)
sometimes wiggling the cable at pyramid end would fix it - not something I’d recommend as I’m pretty sure repeatedly doing this might create some ‘wear’.

I’d guess (and only a guess) the ‘no’ connection is not always grounding as it should do, and so it’s left to float - the pyramid sees this as a valid wavering voltage - and so does not start the assign process.

I’ve reported to Squarp ( but it’s good to have different reports) - I’ve also asked perhaps they could add some tolerance into lower voltage, or
calibration- such that very small wandering voltages were considered to be 0mV - hopefully then a ‘proper’ voltage would trigger the assign correctly.

1 Like

In my case CV and Gate in are never “OFF”.

Also reported it to Squarp.

1 Like

response from Jean from Squarp:

  1. about the small fluctuating voltage, it’s normal, but will improves this display.

  2. about the assign problem, we will work on it for the future update. Is it not possible for you to assign the CV INPUT and the GATE INPUT, or only the CV INPUT ?

(my case is I cannot assign neither the CV nor the GATE Input)


Hey @konrad ,

I’m experiencing the same issue here with a Pyramid that I picked up a few weeks ago, both the assign not working for the main CV input as well as the trembling/wavering voltage reading on GATE.

Rather than go through the manufacturer’s repair process, I’d like to replace my jacks as I’m relatively experienced with a soldering iron. Any way you could point me towards the specific part you used for them?

Much appreciated if so!

Hi, I have the same issue on CV in only, gate’s fine. MKI

Is that a bug or cable contact ?

if cv/gate is working, then it seems unlikely its a hardware issue.

(you don’t give any details of what you are seeing, so impossible to say this is the same in your case… but I suspect the wavering voltage is possibly related)

any how, the only way to know for sure in your case is to report your issue (with details of what you have tested, and how, on your unit) to:

No, it is related to the topic, no pop up. Just the CV, gate is fine

Decided to use the cv and gate inputs after owning a mk1 for a long time.
Have the same issue as others. For me gate input assignment is not working. I have the cv in mode set to assign mono. At the info screen of the analog ins I see that when nothing is plugged in, the cv1 and cv2 are showing off and the G1 shows 0Mv and G2 is fluctuating slightly between 0 and a small value.
I guess this is a Gate in jack problem which is not good for squarp if this has happened to a lot of people.
Definitely not sending pyramid back for repairs because its a minor thing but also annoying!