Arturia Microfreak midi in and out freezes Pyramid

Hi.
Perhaps someone got this to work but I have no luck.
Trying to get midi din in and out to and from Microfreak and Pyramid. I have the right midicables (3,5
mm to din, cable B) from the microfreak. Having the Pyramid sequencing microfreak with only midi in from Pyramids out works. Using midi out from Microfreak alone to Pyramids in works also, but not with both midi in and out at the same time - weird midiloop freezes the Pyramid. I have different synths with merger-box and thru-box connected to Pyramid but when I connect the midi out from Microfreak to Pyramids in, the Pyramid freezes when I´m about to record the first notes from Microfreaks keyboard. Thinking I might have read someone else having the same issue, midi in and out simultanious doesn´t work with the microfreak??
I have tried just having microfreak connected to Pyramids in and out, thinking it might be something weird with merger or thru-boxes but with same results. Tried every setting in midi config on the microfreak and arturias software (same settings as in the synth).
Am I doing something shitty on my side or is it the french fault?
Need help - no fun playing and recording the Microfreak from external keyboard to get the notes into the Pyramid…

/ Daniel

Sounds like the Arturia is using the MIDI Out as a MIDI Thru as well. I don’t have a Microfreak, but I do have a Keystep, and there is a setting in the software editor to set the MIDI out to just do out, rather than thru as well, so might be worth looking at that.

Got midi thru set to off in settings on the microfreak so that´s not it…:frowning:

do you see anything going on in the pyramids midi monitor?

settings->info
you can look at the input, and see if there is a midi loop (hopefully before it crashes)

definitely sounds like a midi loop…

you could also try the Pyramid setting MIDI ECHO= STOP ECHO
its really a band aid, since ideally you stop it on the keyboard/synth… but might help

also look on the microfreak for a local echo (or control) = off setting.

Thanks for all your help.
In Pyramids settings if I turn off clock and sync start/stop under midi in settings, the midi loop disappears. Noticed crazy start/stop action midi loop in settings info screen…
So… If I turn off clock and sync start/stop the Microbrute will send and receive midi as it should. But, my setup in my studio is complex, having different sync options - if I record in Cubase and therfor having that be master clock and Pyramid follow that sync I’m back on square one again. If I want the Pyramid to follow Cubase I have to enable sync and clock.
Can’t find any way to disable Microfreak to send clock, if I could turn that off I think everything would be ok.

Cheers.

Daniel

1 Like

Presumably the Pyramid is connected to your computer (and to Cubase) with USB?

If that is so, then you can disable “Clock Sync” and “Start/Stop” in the MIDI In menu, and leave “USB Clock Sync” enabled, it it will still follow the master clock of Cubase, but ignore the any clock signal going into the MIDI in socket.

I’ve just tested this with my Analog Rytm in a MIDI loop with the Pyramid, and pressing Start on the Rytm only runs the Rytm. Pressing Start on the Pyramid starts the Pyramid and Rytm (in sync) and the Rytm follows the tempo of the Pyramid, but not vice versa.

Opening my DAW (which is Reaper, but guessing that Cubase will function identically) if I press Start on that, then it starts playing itself, and starts Pyramid, which starts the Rytm in sync. Tempo matches that of the project in Reaper.

Hope that helps!

1 Like

cool, great news you have found the source of the issue - top job!

seems to have been a known issue
https://forum.arturia.com/index.php?topic=101089.0

Im guessing they’ve not fixed in later firmware…

as @Loz says, you can choose to send and received clock independently on din and usb.
so if your using pc/cubase over usb, then listen to clock on usb, but not on midi din.

this is a bit confusing…
CLOCK SYNC refer just to MIDI DIN
USB CLOCK SYNC is just usb

iirc…
START/STOP ,is just for MIDI DIN as well.
so USB CLOCK SYNC, is used for midi transport control over usb as well as clock

pretty sure this is correct, I think I only usually have USB CLOCK SYNC turned on… (*)

try that , and let us know how you get on.


( * ) though, I have a mioXM , so I tend to put midi filters on the router, just in case I ‘accidentally’ turn the clock on the wrong device :wink:

Thanks!
I now have Pyramid plugged to my pc with usb and disabled midi din sync. Will try midi in and out from Microfreak soon.
Had problems with powering Pyramid with pc shut down cause I want to be able to start Pyramid without starting my pc, had to make some changes in power controll settings.

I use a powered USB hub for that, which is a decent workaround, and has the added bonus of reducing ground loop hums, too.

Great tip!
Cheers.