Anyone know why my Hermod might be crashing so much?

Hi, Like I said in the topic my Hermod is crashing very often (around 1-2 times per hour session). Most of the time its when I only have around 3 channels getting output. Two channels of quantized CV for melodies and a channel or two for LFOs.

I have tried updating the firmware and backing up and removing excess song files but I can’t think of anything else I should try to fix it. Any other ideas on what it might be? Is there a more stable firmware I could use? Does anyone else have this issue?

If I can’t solve this issue and its not a firmware issue, could I send it back to Squarp to have them look at the electronics to make sure everything is fine with it?

I absolutely love this sequencer… I work really well with it now but the crashing is really getting to me.

Here is a link to my rack, as it might help diagnose the issue. https://www.modulargrid.net/e/racks/view/966536
I am using the tiptop uZeus boost power adapter.

honestly it sounds like a hardware issue…
i don’t think mine has ever crashed, on any of the firmware versions, and i don’t see many reports here of others having it ‘crash’

I guess, you have already tried to determine if its something specific you are doing with it…
e.g. some kind of combinations of effects, or configuration, but seems unlikely to me.

In eurorack one problem that can crop up fairly frequently is power supply issues.
unfortunately unless you have multiple eurorack cases with different PSUs, or a friend with a eurorack setup - that’s not easy to test!

perhaps, it might be worth trying to unplug all modules except (eg) harmod + plaits and seeing if the issue persists?

Hi @thetechnobear,
I have tried it with two seperate uZeus power supplies that I have and with a Meanwell 65B and I still run into the same issue. I do have multiple cases so I will try running it in a separate case and see if that fixes the issue. I will let you know if that solves the problem!

I will sit down with sticky notes the next few times I sit down to use it and take notes on what I was doing whenever it crashes on me. Maybe that will help me trace the problem.

Lets see if I can send it in to have it looked at/replaced

1 Like