Aftertouch is being sent inverted

Hello community. I am plugging in a ROLI Seaboard Block into my Hermod via the DNA connectors of a ROLI Lightpad block.

All of the blocks are set to single-channel. The seaboard is playing on MIDI channel 1, and the Lightpad is playing on channel 2.

When I create a 3-track voice, with Aftertouch and Velocity, the Aftertouch parameter seems to be inverted, meaning when I play notes on my ROLI, the harder I press the lower the voltage of the signal coming out of Hermod.

Is this a hardware issue? Is there a way to correct it by inverting the signal on Hermod?

Attenuverting it does not solve the problem as I don’t want to use an attenuverter each time I do this. Additionally the Aftertouch parameter constantly reports 0 voltage unless pressed. In this case, it constantly outputs +5 voltage because it seems to be inverted.

indeed seems inverted
you should report as a bug via :

i guess what Id do till theres a fix, is use something to send pressure as CC.

1 Like

I’ll check if that can be switched around in ROLI Dashboard and update the thread if I find a way. Not likely though.

Can’t be switched. Submitted a bug report. Let’s hope the team answers :woman_shrugging:

1 Like

Fixed in the last OS release, version 1.4!