A Rample amount of confusion!

I love the potential of Rample from all the videos I have watched of it, but unfortunately, that has not translated to my actual use of the module. I will admit that is probably more due to user error than the design/function of the module itself. Besides using a gate to play a sample, I have difficulty succeeding in any other patch execution.

I would like to have SP1 have a sample with four layers(each layer is looping) and then use a slider (0v-5v) to select which layer is playing.

This is what I have done:

  1. Press “assign” then “1.”
  2. Select “SP1” and then use the encoder to select “LAY.”
  3. Press “assign” again and then “1” to active layer mode.
  4. Press “1” again and select “Manual.”
  5. Select menu and assign CV IN to 0v-5v

What happens:

When I patch the output of my slider to the CV input for SP1, nothing happens. Obviously, I am doing something wrong here. Can someone please help get me on the path to success?

On a side note- I tried the settings above and sent a steady gate into the gate input and tried different layer settings such as “random” and “cycle,” but each time the gate was received, it only would play the first layer.

If I understand correctly:

  • You send gate to SP1 and it triggers a looping sample
  • You send CV to an input routed to Layer on the SP you are currently playing looped and you are expecting the sample to change

If I got that correct, then the Rample will not function in this way on a single voice.

I’m not completely sure if this is correct with CV, since I use MIDI with my Rample, but once you send the command to change Layer, then the new Layer will play the next time the Layer plays.


  • SP1 → Layer 1: Trumpets;
    Layer 2: Bassoon;
    Layer 3: Sousaphone;
    Layer 4: Feeding time at the baboon enclosure at the zoo
  • Trigger SP1, and Layer 1: Trumpets starts playing/looping
  • Send CV to change layer to Layer 4: Baboons (or do this manually, I’d guess)
  • Nothing happens (as you noted)
  • Close the gate, and retrigger SP and it should be baboons

What it sounds like you want to do is basically have four Layers playing and swap between them, which I don’t think would be a function of the Layers feature and probably better suited to using all 4 SPs. How you would trigger that would depend on if you want them to be in sync with each other, or start ‘new’ when triggered.

Hey! Thanks for taking the time to reply. What I am trying to do is sort of replicate what is done in this video: Ambient tips and tricks with the Squarp Rample + Longform ambient performance. - YouTube

I have a slider that goes from 0v-5v. What I was hoping to do is be able to have 4 sample layers (say on SP1- in this case, each a different synth sound of the same note) and as I move the slider up and down, it would trigger the different layers.

But I guess I am having a rough day because I just can’t seem to get anything to work right.

1 Like

Hey, it’s not a rough day - it’s a glorious day of learning new things and overcoming problems!
If someone has a video doing what you want to do, then you can do the thing, right? We’ll try to brightside that.

It sure seems to me that he uses the Faderbank to select the Layer, then uses the touch controller on the lower right of his case to trigger the voice anew.

Yeah- I have a fader and I was planning on using a random gate for the trigger. However, I am just having trouble with the basics since my Rample(which has the latest firmware) doesn’t seem to be acting like it should.

To select layers the manual states: “Press assign, release it, then press ① ② ③ or ④ to enter the layers mode: the screen displays the running layer of the voice.”

When I press assign it always shows the triangle with the “1x” if I then press “2” the top-left dot starts to flash. Here is a link to a little video of it:

Yeah, something strange on your Rample compared to mine.

  • I don’t get the “x”
  • When I select the Layer Mode, the upper left LED does not flash like yours

I haven’t seen this behaviour, but I might assume it would have to do with either a problem with the preset/samples and/or data corruption:

  • Does this also happen with one of the stock Presets?
  • Are these samples stereo? Can you try to make a new Preset with the same samples but in mono just to see if there’s some issue there?
  • Have you tried reformatting the SDCard, reloading (from brand new) the stock presets and trying to duplicate?
  • Also I would try reflashing the latest OS, from a reformatted SDCard if possible.

If that problem persists, I would send a msg to Squarp via squarp.net/contact and include a link to that video.

Edit to add: The “x” might be a CV thing and since I don’t CV, then I would expect my own ignorance there.

1 Like

Thanks again for the help and advice! Yeah the “X” is because I assigned the CV to “Layers”. However, when I press the assign button and select “2” it should then switch to SP2 (so I would think)

I have tried this with the basic default presets and samples. I hate to say it but I would be relieved if it was bug, at least that way I can take solace that I was at least following the procedure correctly.

Well, I would also consider that flashing upper left hand LED to be unexpected.

  • re: switching to SP2: so, these are mono samples then?
  • If you have tried with the the defaults, does it behave the same way?
  • The LED is bright so I can’t see what you click, but it looks like you are clicking for SP2…no?

So if my confusion over the display is unwarranted, then it sounds like you are doing correctly and setting SP2 Layer Mode to Manual. In the video, it does not look like you try to change the Layer tho

Sorry I should have shot that in the video- I had already selected SP2 and assigned the CV to “Layers”. I dunno- maybe I am not pressing things in the right order. To be honest this dot interface with multiple pages is a bit hard to navigate.

LOL- just the way the day is going- I tried to submit a possible bug using their contact form and attach the video and I keep getting an “internal” error message. :disappointed:

I am SO SO Sorry if I’m terribly confused.
I’m confident we can figure this out, but dealing with me is probably more frustrating.

  • I am terribly annoyed by your screen not refreshing. When I click Assign after the >1x screen, then I just see dots for each Layer and a single number displaying the number of the Layer that is playing/just played. And when I access the Layer Mode, the dots representing which Layer is selected (the flashing dot) is not flashing. I find this concerning and do not know why it is doing this, but it might be a clue if the problem is system oriented.

  • If you set the Layer Mode to Manual, you can then select the Layer with the main encoder and press the encoder and that layer should play. Does this work as expected? Can you try Random and Cyclic also, and do these work as expected?

  • If you send your varying voltages to the CV In, you can use the Encoder to trigger the sample (at least you can from the Layer Select screen). Troubleshooting advantage here is that with every trigger of the SP, the large number to the right and the flashing dot will indicate which Layer is selected. Does this work as expected?

  • Your OP was about SP1, but now you are working with SP2, correct?

Honestly, I rarely look at my Rample because I set up my presets and control everything from outside the box via MIDI. It’s a dream module for me: no hands once it’s set up.

Sorry. That’s probably me rubbing off since Murphy’s Law runs my life!

That must be terribly frustrating.
Sorry you have to go through that - but if you can get the msg to Squarp, they are usually amazing at resolving stuff.

No worries- it’s just nice to have some help! I think I might have solved the issue- well at least by selecting the layers via the encoder. I just have to do a quick test. I’ll report back soon.

1 Like

Ok I got it! So I think there is a bug (maybe?) but I seem to have found the process that works.

  1. Press “Assign” and turn the encoder to the sample bank desired (>1,>2,>3,>4)
  2. Press Mode button that corresponds to the sample layers desired.
  3. Press the encoder button(this will play a random layer)
  4. Press the Mode button again to activate “layers”
  5. Turn the encoder to select “manual”
  6. Press “Assign” and select the sample bank
  7. Use the encoder to assign the CV to “Layers”

Now the incoming gate signal will trigger the sample and using the fader slider will change the sample layer. I believe the issue was I was doing step #3 and that was causing it to freakout.

I’m glad you got it.
I’m confused, tho:

  • Pressing Assign and the >1 >2 >3 >4 on display is representative of the CV in. This is to Select which CV In you want to Assign. After selecting that with the encoder, you can select which SP to Control, and then which parameter you want to control.

I thought you just wanted to set the SP’s Layer Mode to Manual, which is:

  • [Assign] → [(1),(2),(3),or (4)] (pitch, bits, filter, freeze) to get to the running layer screen,
  • then [(1),(2),(3), or (4)] again to get to the Layer Mode selection screen
  • Select the Layer Mode with the Encoder & click

So yeah: sorry - I led you astray.

LOL- you didn’t lead me astray at all- you were very helpful. TBH- I am not even sure I know how it works, I just know I have been able to recreate it a few times now and it seems to work as I wanted it to. I wrote down the steps so I wouldn’t forget.

I really do appreciate the help! Have a great day/night!

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.