USB MIDI & Logic 10.7

I’m looking to control software synths and samples via Logic Pro and previously could do so fairly easily by assigning USB MIDI Channel @ the track level on Pyramid as well as in Logic, however, now I don’t get anything when I assign a software track to any USB MIDI Channel.

I’m wondering if this has something to do with Logic 10.7’s “MIDI In Port” ?

I use a MIO XL to route all my MIDI and it’s working great with all my gear, however, with soft synths + samples no dice. Anyone else run into this per chance? Maybe I’m missing somethign simple?



The first thing I’d check is the routing in the mioXL. When things behave weirdly in my setup that’s usually because I’ve changed a few things in Auracle and messed up the routing or added filters in the wrong place.
An essential tool for diagnosing issues like this is Midi Monitor. If your notes/cc from Pyramid are showing up in there, check what you’ve done in Logic, if they don’t, check the MioXL.

Thanks @polynil .

I did some further experimentation and routing in Mio (via Auracle) is good.

I was able to figure out how to program soft synths or samples in the Pyramid again by assigning “MIDI In Port” in Logic to the Pyramid via my Mio (screenshot below) - and assigning the proper “MIDI In Channel” - so that’s good.

The only “problem” with that is the connection is on my “A” channel on the Pyramid and still not USB MIDI. I’d rather take up MIDI Channels on USB for samples etc. and save my A or B MIDI channels for real synths or pedals. I think this all comes back the the new(ish) “MIDI In Port” setting in Logic - need to figure a way for the Pyramid to be recognized there via the USB connection.

I opened a ticket w/Squarp Support too - I have a work around for now, kills me having those extra 16 MIDI channels sitting unused on the USB side of the house though :wink:


Very weird. I’ve just tried to replicate the issue. As soon as I had added a connection from Pyramid USB to a Computer/DAW port I could play the synth in Logic. Selecting the actual Midi In and Port in Logic worked as expected as well. (Pyramid USB Channel 16)

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.