USB midi disconnection - MacOs

Heya, next one.

first: the nomenclature seems to be reversed within the Hapax:
Host vs. Device.
??

second:
i got the USB connection working to my PC ( seeetings set with reversed nomenclature)
But i a lose the connection to the PC sometimes.
Thats NOT doable to do so any work / since to bring the connection back is the plain PITA and not something straight forward. ( Mac-BigSur )

anbody else ?

The USB Cable from the Hapax goes into my main USB Hub ( active) / Never had any connection problems bevore ! ( M1mac / BigSur)

The nomenclature is from the point of view of the Hapax … it is it acting as a device or host.
It’s consistent with how they have done it in the past

Unfortunately doesn’t matter which way you label it, some will think it’s the wrong way around :slight_smile:

Hmm, I’ve got mine plugged into M1 Monterey never seen a drop out.
My first video was using bitwig to host a number of vsts … and never glitches during hours of use.

perhaps cables? try wigging the cable ( slightly) at both ends see if it’s faulty?

ok, thats good to hear, and gives me motivation for further investigation.
The cable was allways working fine with my Digitakt. but i will try other cables also.
not donne that so far.

unfortunately are ALL my soundcources i wanted to use the Hapax with, just plugins :laughing:

Your help is much appreciated Mark ! Thanks

1 Like

some feedback:

i exchanged the USB cable, just to be save,
i changed the connection, going now “directly” into my TB3 hub, so no USB hub any longer involved.
This solved the problem,…at least for some time.
BUT: i had again complete losses of the whole USB connection.
restarting the Hapax solved the problem.

NEVER had any such problems with all the involved ITB part, the software, nor with the usb hubs i´m using now.
Well, i use something like three novation controllers, up to five in past days,
and sometimes one would lose its connection.
then i unplug and replug the usb cable on the controller, and all runs fine again.
Such unplugging did not work with the Hapax.

Gues, here is something to watch !

odd, you’d not really expect a hub to cause issues (esp. since hapax is not powered by it)

I’d raise it with Squarp…

they can then track if more users are reporting the same issue.

I’ll also rename this topic, so that if others are experiencing the issue they will find this topic… and so we get more feedback, and again they can let Squarp know.

1 Like

because i saw this post here, i tried using the Hapax with Usb. And the first approach wasn’t successful either. Tried 3 cables, 2 computers… nothing worked

Then did a Hapax restart and now it works.

1 Like

send a bug report via the contact form , including details of computer setup (type/os etc)

also include :

  • error/warning messages in computer logs
  • is it seen as a USB device? recognised as midi?
  • are you plugging in the USB cable AFTER the hapax is powered on (hot plug) , or before. (*)

hopefully, if Squarp get a few detailed reports they might be able to see some commonalities, and perhaps reproduce.

btw: one thing Ive noticed on macOS ,whilst most applications (e.g. major daws) do recognise a new midi device coming online if its plugged in whilst running… some do not, or some will not automatically re-associate it with the input source.

(*) I tend to have my Hapax, plugged in … and never seen it not recognised. (either by my mioXM or Mac)
… so I wonder if perhaps its a hot plugging issue?
though even then, this still works for me :confused:

1 Like

couple of extra ‘data points’
(previous testing with M1 Mac Mini - Monterey)

I tried with:

  • older MacBook Pro - Intel i7
  • older Lenovo i7 laptop on Windows 10

both connected first time , every time I tried…
I tested both hot plugging, and with hapax pre-connected, and also with and without usb hub.
worked flawlessly every time.

disclaimer:
I don’t use these laptops regularly for music making, so won’t do ‘long term’ tests on them…
(simply because, the MacBook battery is dead, so its a pain, and I dislike windows, and only use it when I have to release software for it)

so these were simple are connectivity tests… does hapax get recognised, and is it operational (e.g. in Ableton Live).
I also don’t have any other devices plugged into them (not that this should really matter) or use them for long periods of time (e.g. to see time dependent disconnections) (*) - so ymmv.


(*) for the laptops listed above,
my Mac mini m1, has lots plugged into it, including things like audio interfaces… and is used for hours on end, so I consider this representative of normal use-cases.

1 Like

No, i plug my devices in, and keep them so. its a stationary setup
( i can post pictures when a picture thread was started :wink: )

(optional Info) also, my main apllication is my plugin Host, NOT a DAW ( Gigperformer).
this thing handles the whole midi connection thing as good as can be.
AND: has a built in midi monitor, i can click at any time.
I even can connect it to specific “midi input devioes”.
and these show me also every available midi port. ( its like a modularsystem in software / the midi in devices are like own little modules / ist super quick and handy to check vs. ANY such problems with midi connections)

Also: i can shut down my usb-hub for all my main HW controllers, as i like, and switch back on and never have any problems ( i do that all the time) Everything will be recognised immediately and will be shown.

thanks ! this definitly helps ! i´d not donne that good enough then.
I give it some more time bevore i report.

To me it seems that it is related to some button presses.
( pressing track buttons seems to be involved / and: i have problems with mute unmute / AND: might sometimes press “unprecise” and press a button more, than meant to be)

1 Like

yes, same scenario.
i´m on aM1macmini too :wink: / latest Big Sur

Alots of HW midi controllers connected.
but these are ALL on one own USB-midi Hub.
usually two audio interfaces, one per thunderbolt connected. (TB3)

plus a thunderbolt dock ( TB3)…and the Hapax now connected to that one.
No other permanently data emiting device on that TB3 dock, other than my 2nd screen

1 Like

It’ll definitely be interesting to look in the ‘Console’ on macOS to see if it looks like the USB device disconnects… or other errors.
as the first question is… is Hapax ‘disappearing’ or simply stops sending data and responding?
… and of course, why does it ‘all of a sudden’ decide to do this, when it’s previously ok.

in my plugin host: (which is a very sophisticated piece of software)
does it disappear !
i can definitly say that.
…its then no longer shown as a available midi interface.
same with Pianoteq standalone

i have no experience using the mac console / how would i check there vs. the Hapax ?

yeah, Im familiar with GigPerformer , I’ve know the developer for a while :slight_smile:
(from Eigenharp days…, music tech dev is a very small community !)

hmm, if it disappears… I used you’ll like see its disappeared from macOS level too, if you look in the audio/midi utility.

Console just search for app with spotlight.
(the issue will be more finding useful information… as its really just a bunch of log files)

it’s interesting its only does it with your hub… as if the hub is throwing it out?
this kind of thing, id attribute with power issues, but the hapax is not bus-powered !

to make it clear:
i had the Hapax on the USB-Hub (active) and it was thrown out. several times, too often.
And have it now on the TB3 dock. And was thrown there out also. But way less ! just once i think, or twice. But allways: i have to powercycle the Hapax. Just a USB-cable, dis- and re- connect was not good enough.

Ok, i try to keep this in mind.

interestingly, i just saw the “sync issue” thread, that there´s a relation to mute-unmute tracks.
I was under the impression that this case here -in my setup- was also related to my button presses. Thats was alos the mute-unmute thing.
To notes: i had there difficulties,…so i would press more, and maybe a little bit “unrelated” that you´d otherwise do.
Also, could it happened that i pressed more buttons than wanted, for example a pad also.

i was under the impression that there was a relation

interesting.
GigPerformer has opened doors to me. Big times !

1 Like

Not very helpful but I’ve been using my hapax with a new mbp over usb since I got it and haven’t had it disconnect even once. I’ve used it with a hub and direct.

1 Like

I can’t reliably reproduce it, but haven’t had several times where my Hapax drops connection to my mioXM (which is connected via USB). Generally seems to occur when I hit stop on the Hapax, but not consistently repeatable, so not sure what’s going on. Rebooting the Hapax fixes it. Going to keep testing it and I’ll make a bug report after I have more data.

I’ve been able to reproduce a problem where Hapax drops all MIDI connections and will not output via MIDI after a reboot (but it shows MIDI data generated and sent to MIDI out in the MIDI monitor), but not reliably. It seems more likely to occur when I have a LFO set in the MIDI effects. The only fix appears to be deleting the settings.bin file, which is a bit of a bummer after I spent some time tweaking the LED colors to my liking.

Deleting the lfo didn’t help?

Bizarrely yesterday I suddenly lost midi from hapax to ableton, but not other hardware synths, assumed it was hapax due to this topic - so Rebooted hapax , didn’t help.

But then noticed mac was getting midi , turned out ableton just wasn’t getting midi from anything … restarted ableton, all ok.

Now not sure if it’s ableton, or the recent update I just put on the mioXM - arghh

I guess next few days it’ll become clearer.