Switching off interpolation?

I can’t figure out how to switch off interpolation for the automation lanes… I see It says “inter: on” but turning/pressing the encoders doesn’t change it. The manual doesn’t say how to disable it either… anyone tried this yet?

Also, this thing is pretty brilliant overall.

I couldn’t figure out how to disable interpolation, either.

Just checked and turning the encoder (far top right) to turn interpolation on/off seems to work here.

Hmm I still can’t seem to get it to work. Turning the dial does nothing

Oh weird I can turn it off for effects automation but not cc

Continuing my discovery: I can turn it off on other tracks but not the first. Will be filing a bug report

its NOT working for me either !

  • it did NOT work on automation lanes “programmed” on the pads
  • i DID work for recorded automation data
  • if i re-programmed these on the pads, was intrepolation set back to on, with me, not having any access to disable that again.

my controllers are sucking anyway ----> when beeing in this whole menu,
while i do not have a encoder caps problem otherwise

Please send Squarp a bug report. I’ve filed one as well, but more data is helpful

1 Like

Could someone post a project where this doesn’t work ?
( assuming it always fails on same track after reloading project.)

answering your post on other topic ,re this , @Funky40
yes, Im able to turn interpolation on both recorded data and cc’s I enter manually.

1 Like

ok, did some quick testing… and found two issues, the first is probably the one you are tripping up on

(also a workaround, so you can buy me beers later :laughing: )

a) interpol is only working on pattern 1 , other patterns have it locked

b) recorded automation lanes, that don’t exist in P1 have might bring up an error message.

Ive sent these to Squarp, so they should be able to reproduce and hopefully fix.
Ive also recommend they take a look at other automation parameters, and check they are working for P2-8.

ok, so what’s the workaround, and also why had I not noticed it?

  1. when you copy a pattern with automation, that interpol is copied.
    so if you set it correct in P1, then copy to patterns, it stay as you set it.
    ( I don’t really see this as too bad, since usually you know if you want interpol or not from that outset)

  2. copy automation from pattern 1
    you may have noticed (or not) that the automation menu has copy/paste
    so you can set automation on p1, then copy/paste to other patterns (if you need it different)
    of course, you loose you current automation, BUT thats ok, you can copy this (with ALL+copy) to a different pattern first… copy p1 to get the interpol, then paste the data back.

of course, being workaround neither is ideal, but works until we have a fix.

1 Like

Ok, thats very valuable infos again !

i´m still in “checking everything out” mode !
I need to check things out, to decide how exactly i´ll use/approach my Hapax.
this definitly helps, “here, on this” !

Big thanks one more time Mark !

1 Like

more feedback:

copying my Track 5 to Track one, which contains “only” automation Data yielded to:
…on Track One, i stall can´t set interpolation to off.

deleting Track 1, adding then by new a fisrt and second automation lane, from “Automation” mode active, trying to set interpolation to off, is also not working !

both: with NO automation data set.
And: with automation Data set ( on the pads)
Output is set to: CV1 / CV2

collecting data here / i deal with health issues right now, i´m not gonna deal with comprehenshive bug reports right now, i guess / well, i might do when i have a complete picture / personally, i fear now, there is more complexity involved in this “interpolation-on” issue , than thought.

( this one, is a major one for me, for example / i NEED to have this)


creating ahain a fresh CC line (after deleting everything on that track 1), not CV, could i set interpolation to off, …track 1.
check on track, 5 and 10: worked also !..CCs , Not CV

But; now i tryed again with CVs, ie, the output set to CV1…as is in previous trys that did NOT work: now, worked !..track 10 right now, track 9 alos: works.

Is this happening on pattern 1?

Honestly, id not be too concerned …
the bug report I’ve sent @squarpadmin reliably reproduces the issue every time , from a new project … so they will be able to replicate.
And although there may be variations , my experience is often fixing the one we can replicate will lead to fixing if others related issues.

What’s quite interesting in what I found, is that you can copy/paste from other pattern to get it working - so this tends to imply it’s almost locked …
So I guess there is some state that is supposed to prevent changing Interpol that is incorrectly being triggered.

1 Like

ahh, first: i mixpuzzled “tracks” with “patterns”.
But: yes, that was allways on pattern1…and it was mostoften NOT working out, on “all the tested Tracks”. Allways pattern 1.
just when i posted yesterday was it beginning to work.
ok, now i understand !
but: the problem was real, even on pattern1.
So, there is some inconsistency vs. what you´ve experienced

not really, I cannot reproduce for P1… but that does not mean it can’t happen on P1.
as I said, there is obviously some kind of ‘locked’ state it can get into, it might be that there are other scenarios e.g. perhaps copying from other tracks.

but, Im hoping with one reproducible use-case, Squarp will be able to fix the underlying issue.

btw: you could try the copy/paste trick I mentioned, Id guess this will work in most circumstances, as essentially it appears to reset this ‘locked’ state.

note: many I say locked, I do not mean the lock automation… it is not related to this, as I tried to see if lock/unlock would some how reset the Interpol, and it didnt :wink:

yes, i´ve donne that :wink:

i´m still in test mode, its hard to remember what was donne which way.

That’s a confirmed bug.
Will be fixed in upcoming firmware update.