Stuck gates in Polyphonic tracks?

I am trying to figure out if this is a potential bug:
I have Track 5 set up to be 3 voice polyphonic (pitch and gate). I am using midi in to send “unstaggered” chords (i.e. all 3 notes go on and off at the same time).
When I do this however, it appears to be a bit of chance that some of the gates will not turn off at the end of the “note”
I can see this on the LEDs: All 3 go bright at the start of the chord, but only one or two dim at the end of it.
I am trying to duck all 3 at once, so I only have the gate of the topmost output connected to a VCA, unfortunately, that does not always appear to be the one to stay on.

I’ve tried the various allocation modes, but they all behave the same way.

Video of the issue here: https://www.youtube.com/watch?v=JF-cpSsml7c

OK i’ve narrowed down the issue: If you send a 4 note chord to a 3 voice track, the allocator gets “confused” and seems to loose track of what to do with the 4th note. In a sense, Hermod sees 4 midi on messages come in. note one goes to voice 1, note 2 -> voice 2, note 3 -> voice 3, but then it gets note 4 -> and reassigns it. This part gets a little fuzzy, but then it gets 4 note off messages, but at this point, one voice is “dropped” so I think it ignores that message, leading to a stuck gate of some sort.

The workaround is to make sure you only send 3 note chords to a 3 voice track.

edit: maybe not :frowning: even sending only 3 note chords, some still get stuck open

Ok I tried changing the clock source from internal to external and back. just flipping between the two seems to have resolved the issue? both 3 note and 4 note chords are behaving, with all gates going on and off together…