Strange quantisation problem

Hi everyone , I’m new on this forum , just got a new pyramid and I’m experiencing a strange problem.
I have it as a slave to Ableton. I also tried as a master to ableton.
When I try to record an external drum from the live mode , I cannot get the quantisation working on it, neither quant option on
Misc, nor quantisation on humaniser .

Anyone can help?
Thank you very much for your help


Im not quite sure what the exact problem your having is, nor how the pyramid and ableton relate…

one thing to be clear, quantisation is not done on ‘live’ input, notes are only quantised when you play them back - apart from that it pretty much should be just turn the quantiser on.

is your issue definitely quantising, and not sync? e.g. if you want very tight sync between the two units, your best bet is to use ableton as master and then use delay compensation (in ableton)
(Ableton’s help docs cover this)

Thank you very much for your answer.
The issue I’m having is that quantisation is not working at all both as master and slave.
I know that quantisation is not audible when I’m playing but it should be on the playback when the loop starts back again.
I’m starting to think that there is a problem with the unit or could it be the firmware ?
Don’t know …
Thanks again

sorry, there’s just not enough information in your post to tell what’s going on…

saying “its not working” doesn’t really give us any clues about what is happening.

no, its does not sound like a hardware issue, and Ive not seen any reports of issues in the latest (or others) firmware about quantisation - so it feels like it’s going to be a misunderstanding, or some external factor that you’re not describing

I guess what you try is this:

  • ignore sync for now, so just do with pyramid internal clock
  • set a slightly slower bpm , say 75… so that the following is easier to hear.
  • place down a 4 on the floor kick on T1
  • on T2 place a note on step 4 (to it would hit on second kick) , offset this note (manually) by +10 %
  • play … you should hear T2 is off on step 4 (compared to T1) due to the offset.
  • put a quantiser on T2, turn it on and set to 1/4
  • now press play , and it should be ‘in time’

if this works as above, then quantisation is working…

and if you have pyramid as master, then nothing changes (by sending clock to Ableton)

so from here you can describe what’s ‘wrong’.
if its something out of sync in ableton, that is, as I said before, due to not using delay compensation within ableton correctly.

please note also , how I described a scenario, with details and expected outcome - this is the kind of level of details we need to help resolve issues… otherwise we are shooting in the dark,

please also understand im not an employee of Squarp, Im just doing this to help users in my own free time, so im grateful if you can give me as much as possible to help me help you quickly.

if you want official support from Squarp, you will ned to contact them via the contact form , but be assured you will need to provide they same kind of information as I have requested , if they are to help you :wink:

Thanks for your answer. It was very kind of you to dedicate your time to help me.
Sorry if I did not explain myself properly.
I think it’s just the way the quantisation works on this machine.
I tried your method and quantisation actually works .
It’s just that when I use my mpc it feels like that the 16th note quantisation works differently then pyramid when I try to do the same. Even a simple drum pattern , it seems that it’s not putting the put them on right 16th .
I don’t know how to explain better. I could make a little video and post the link here in order for everyone to understand better what I’m experiencing.
Thanks for your time .
Really appreciate it

I was thinking .
I have 3.5 firmware, could it be that I have to update the pyraos?

I don’t think there has been a bug in quantisation , Id update it to latest version … nothing to lose, and there are optimisations from 4.x onwards.

if its working in the test, then it is putting them on the 1/16th (or 1/4) , so im not quite sure what you mean its different to the MPC…

If you record something and have quantisation on, is it lining up with beats that you program on the Pyramid? (Id assume from previous test, it does)
in which case, it sounds like the pyramid is ‘correct’…

so Im not quite sure what you are expecting,
I don’t know why it ‘feels’ different to the MPC,
are you sure you haven’t got something like swing on?
or does the MPC alway move later, rather than bringing to closest quant boundary (so some times bring it forward)

I think what you have to determine is what is different , not ‘feel’…

Im not sure how you are comparing… and so know its different.

one thing you could do is to record audio into a daw, and look at the waveforms of both.

you don’t need to sync with the daw, just use the same tempo.
then you can align the first ‘beat’ to the grid, and see where subsequent beats are landing.

it might not be 100% (i.e. sample accurate) but you should be able to get it to 1/64 or so , which is close enough for testing.

if you do this, then perhaps this will show you can demostrate the pyramid is not doing as you expect, and so could be the subject of an issue report you can send to squarp?

but, Im guessing (and I don’t have an MPC) that the MPC and Pyramid might have slightly different quantisation settings, and perhaps this is creating misunderstanding rather than either of them being ‘wrong’

Thank you for your answer once again
It just suddenly started to work.
Now the daw is a little delayed respect to the pyramid but I don’t mind. Nothing changed in the setup.
It was surely a communication problem between Pyramid and Live . Don’t really know or understood what it was.
Anyway, thanks for your time , I really appreciated it! You’re great
Best regards

this can be ‘fine tuned’ with compensation in Live.
however, dealing with delay/clock compensation can be tricky at first… its quite a big topic.
the Live manual is very good, but I think many find it a bit technical/dry,

Id guess there must be some good you tube videos out there.
(though beware, Ive seen some really bad and also plain wrong explanations too, so once you understand it, its worth double checking understanding with the Live manual)

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.