Shorten a loop by half a page

So I’m loading a midi loop from another device by playing it in real time from the other device into the pyramid. Problem is that the end of my long loop isn’t a perfect match to seamlessly loop back to the beginning. If I dial the length back a page I still dont end up at the right spot. If I go into step mode and start erasing steps I end up with a silent spot before the end loops back to the beginning. Can I shorten a loop of say 64 pages back half a page to 63 1/2? Or do I have to edit in a daw?

I don’t think you can do this as it stands with the pyramid unless the track is less than a single bar, then you can set it to 1/4, 1/2 and 3,4 of a bar, if the track is longer than 1 bar then it will be full bars only.

However if this untrue I’m interested myself

It would be a cool feature if you could sweep a cursor to a spot in step mode and chop it there to be the end of a loop.

1 Like

In your example of a 64 bar Track that you want to shorten to 63 1/2 bars:

  • Press & Hold [Track] + [Length]
  • While holding those, Press the Main Encoder and rotate counter clockwise until the screen says 63 2/4 (unless you’re using a time signature other than 4/4, at which point I’d assume you can do the rhythmic math to figure that bit out)
  • Release
1 Like

Thanks, I didn’t realize that you could get divisions of a bar by hold the decoder down. My loop point still doesn’t match up because my tapped in time signature isn’t 4/4 or 3/4 but some hybrid that might take einstein to calculate. I still would like a “loop from this point” marker in the step mode.

Apologies for misunderstanding your query.
I’m not sure what you mean by ‘loop point’ - I understand what that term would mean in other contexts which aren’t applicable to my understanding of the Pyramid (sorry - I’m an idiot) - but it sounds like now you’re having issues with the 1 of your Track perhaps? As in: You want to move all the notes towards the beginning or to restate that: perhaps the first note is occuring on Step 9, but you want it to occur on Step 1.

If that is the case, the function you might want to try is Rotate which allows you to shift all your notes one direction or the other. Using Zoom in conjunction with these commands might make things a bit easier.

Edit to add: Sorry, my manual links barf’d.
I’ll see if I can fix these, but in the meantime, every piece of information I’ve used to respond is available in the manual



And since it was mentioned earlier, Track Length:
(Shortcuts - In Any Mode)

And in the Manual, Track Length is under Zoom in the Track section:

Actually, strike that last response from me.
Apologies again - I missed the part where you mentioned your time signature is not 4/4 or 3/4. If you’re using irrational rhythms, then I’d probably need some more info such as:

  • Are you in Polymeter or Polyrhythm mode?
  • What meter are you actually using?
  • Have you considered just importing the MIDI file? (Sometimes the path of least frustration is the better…or at least less frustrating which for me saves money on my visits to the liquor store)

A loop marker in a daw is a point you set on your timeline to instantly return to start and continue to play, creating a loop from that point. You drag the marker to where you want the loop to end before it starts over. I dont see anywhere that the pyramid can do this.

I dont really know yet how to use the poly modes yet. I recorded in 4/4 but can change the sig after its recorded. Changing to 3/4 may solve my problem. The track does sort of have a triplet feel.

I cant directly import because my midi looper doesnt have that capability.

I haven’t clocked the 2 units together but that also would probably at least help me record the exact length loop i want.

The other unit is the bastl midilooper. I’m still a newbie on both units but I’m figuring it out bit by bit.


I don’t think we’re on the same page.

I had the pyramid set for 4/4 by default. I freestyle played a drum track in into the bastl. I dont know the real time signature of the drum part I played. I connected the bastl to the pyramid via midi cable and hit play on the bastl and hit record in the pyramid. I hit stop on the pyramid but did not get an exact clean loop. I went over by a bar or 2. I want to trim the recording in the pyramid to loop cleanly from start to finish. So far I cant find the right spot. Even when I advance the length by 1/4 or 1/3 of a bar depending on if I’m set to 4/4 or 3/4. Its probably not worth going much farther. I will just clock the units together and get it right the first time.

Could be a number of things going on, but since I believe you mentioned being a newbie with both devices, it is most likely just a matter of getting your workflow down.

IMO that’s the most frustrating stage, so perhaps I can relate.

in my tiny little world of misunderstanding, there seems to be 2 scenarios I can imagine:

  • One cause by MIDI latency, so all the MIDI Events line up on intended Steps, just shifted later in time than you want
  • Another cause would be the MIDI Clock not sync’d at all, and the Start is off AND the End is off, and none of the Events line up on intended Steps (such as, two events that are supposed to be 2 steps apart end up 3 or more steps apart).

You are intimately familiar with your music, but let’s do a hypothetical. If the MIDI data you wanted to record onto the Pyramid were just, say, 4 Events on the 4 downbeats of a single bar (such as a 4 on the floor kick) would they be:


Sorry that one image is rotated.
It’s not rotated on my end and both images were taken the same way so if any of this helps with your Pyramid rig, could you help me with my cell phone camera?!?

So, basically if it’s the first issue, then I’d probably look into your system and latency, but the ‘fix’ could be just a matter of using the Rotate function to move your Events earlier. Conquering latency is something that must be done if that is an issue, but that is less Pyramid-specific. Check on the Zoom and Rotate functions in the manual and try some of those.

If the issue is the second example, then I think there might be a sync problem going on in that the Pyramid is running at a different BPM while recording than your sending device is using. That’s a matter of Pyramid Settings, sending MIDI Clock out from your looper, setting Pyramid to respond to incoming Clock, etc.

Nevertheless, as stated before: If you’re a n00b to both of these devices, then you’re still defining your workflow, so enjoy this bit. If none of this data is applicable to your situation, no worries: it will still be here for the next person who might ask a similar question and need this response. :slight_smile:

Thanks. I’ll explore your suggestions.