Scale fx plugin causing note delay?


#1

Hi, still having the oddest problem running OS3.
It seems that when I insert a scale effect onto a track, it causes the 1st note of a sequence to be skipped. I’ve done a lot of troubleshooting on this, and was hoping that someone here could either confirm the issue, or disprove it so I can move on to a different solution. It seems as simple as deleting the scale plugin from the track to cause the first note to play properly, but this is not ideal, as the scale fx is important to my workflow.
If some kind user could check this out, I’d be super grateful.
Thanks!


Sometimes first step wont trigger
#2

Is the first note in key ?
if not, the scale plugin may be removing it, as it is not ‘in key’ ?


#3

Yes, even if it’s the root of the scale, the note is skipped. Also, the note is skipped even if scale is bypassed. Only fully removing the effect from the track causes the issue to go away


#4

Did some testing last night, put a scale device on a track but could not get the first note so skip whatever i did.


#5

Thanks for trying! I guess I need to look into other possible explanations


#6

I just ran into this issue myself. It happens in note and chord modes, with only the scale FX active. Totally empty new project.

When the pattern loops, then the first step plays. But it doesn’t play when hitting the Play button from the start of the pattern.

Even with the scale effect “disabled”, it still happens. The effect has to be deleted in order to get step 1 to play. I find that pretty odd, as a disabled effect should do no more to the sequence than a deleted effect. Moving the scale effect to another slot doesn’t fix it either. Adding the effect while the sequence is playing doesn’t cause any drops, but that’s because the sequence is already playing and as was said, the 1st note in the sequence will play after the sequence loops.

Adding a tiny offset to the first note fixes the issue also. There’s something about playing a note right on the “start” event with the scale effect.


#7

Yep, sounds just like what I’m describing. The offset is a good workaround, but I hope it’s something that can be addressed with a bug fix. Glad I’m not the only one, was starting to worry it might be a hardware issue. Thanks for reporting!


#8

had to double check, i can confirm that it skips it the first time the sequence plays. thought it was skipping it every time the pattern looped. sry.


#9

Thanks for checking again


#10

Bumping this, Squarp support has been very quiet, anyone looking at this, @squarpadmin?


#11

Hi,

This issue is reported. We will work on it as soon as possible.

Thanks for your feedback !


#12

That’s great to hear, any idea when we might look forward to the fix?