Repetitive crashing


#1

Latest Hermod 1.021 firmware. A certain button and encoder manipulation crashes Hermod with instant reboot and loss of all info not saved. Happened twice, before and after new firmware. What can be done ? Upsetting.


#2

Hi brianvega,

This is of course something to fix. Are you able to reproduce it or is it happening randomly ? If you have any clue of how to reproduce it it’s the best way to quickly fix it ! How is your setup ? What do you have in input and output ? Clock in ?


#3

I had this happening as well. Hermod is clocked to a midiclock and sending out cv clock. I was fiddling in the efx matrix…hermod crashed but did not reboot


#4

Hi @crazeebo @brianvega
I tested every parameters possible of the modmatrix, with Hermod synced via its midi input. I do not saw any problems.
If the problem appears again, it would be great to have you last Hermod actions, thanks a lot!


#5

I‘ll give it a try


#6

I tried hard but the crash never came back😃sorry


#7

I’ve got the same or similar problem. Had mine for 2 days. It seems to be something to do with the Step button. Especially if I’m holding it and moving the encoder but not always. I get the issue with v1.01 and v1.021. It’s pretty much unusable as it is so I’m guessing mine is a faulty unit?


#8

@crazeebo
We found the freeze bug related to the modmatrix, we had fixed it, an update will be very soon released!

@DaveyDeSade
It might be a software problem.
Do you have a precise procedure to reproduce your crash? If I understand, you hold the STEP pad and you rotate the encoder. In what mode does it happen?


#9

In step mode on a modulation pattern. I hold STEP and turn the encoder to swap to GATE and about 50-70% of the time the unit resets. It does it at other times to when I’m pressing GATE but this is the most repeatable.


#10

A new version of hermodOS is available, do you still have the issue?
http://squarp.net/hermodos


#11

That seems to have fixed it. Many thanks.