Recording Live with Pyramid

Hello all! I am in the process of getting my new synth setup having the Pyramid as the brains to my setup. I figured I would make this post to help others out as I am seeing people ask how to play and record into Pyramid on the fly which is what I want to do…the same as what MR. TUNA does. I will post my setup and how I believe the setup should be for MIDI as well as the settings needed in the Pyramid. Then all of you more experienced Pyramid users can chime in and add and/or correct to the information.


-Go to each synth and program its channel and set clock to external

-In the Pyramid, Settings → Midi In → Omni Mode: set to Multitrack Bank A

-In the Pyramid, Settings → Midi Out → Midi A Mode: set to MIDI Out (default)

-In the Pyramid, Settings → Midi Out → Sync Midi A: set to SEND

-In the Pyramid, Settings → Misc → Live Looper: set to BEAT or 1BAR


Looks good to me! I just got a pyramid and have a similar setup which I’m gonna try out this weekend.

Yeah, this is similar to my set up. Im interested in how well the RC202 works here. I’m hesitant on buying a MIDI sync-able looper because of all the horror stories i hear - across almost every brand - about clock syncing issues. Usually the suggested solution is to make the looper the master clock, which isnt ideal.

I sold my RC202 because of MIDI sync issues. The sound engine is really jittery and introduces a lot of loud clicky artifacts. If it’s the master clock, then it’s fine, but as a slave it’s almost unusable, annoyingly.

Yeah…I would notice some jitter with the old setup. I am only going to record some loops via my cell phone. I may just disconnect it from MIDI and just time it to the beat myself as I won’t be using it too often. You know how you sometimes hear audio clips from a movie or show during a synthwave song…that is what I am planning to do with the RC202.

The best way to make the Pyramid as seamless as possible in recording multitrack live jams as was shown in the video by Mr. Tuna, is to use MIDI merge boxes and a MIDI thru box. Here is the MIDI Flow Chart that I have developed to make it work.

This design allows you to use the individual synth keyboards to play the keyboard itself (local control ON ) and also send the MIDI info through the main merger into the Pyramid for recording. Make sure you have the “MIDI ECHO” set to STOP ECHO and the “MIDI A MODE” set to MIDI OUT (default) in the Pyramid MIDI settings. Any controllers you may be using, like MIDI Pads or Keyboards, are merged in a second merger and then split to the main merger to get the controller MIDI out into the Pyramid and then also merged back with the Pyramid MIDI out in a third merger to get the controller MIDI to the drum machines and synth modules. This way you don’t need to toggle the “Stop Echo” from ON to OFF when using the controllers as Mr. Tuna had to do. It’s pretty easy to follow by looking at the flow chart.

As an update, I have found a great 5 in / 2 out MIDI merge box that’s only $50.00 It’s by a company called DoReMidi and is sold on eBay. I purchased 3 of them to do my modified “Tuna Technique” merge into Pyramid setup. It works really well. My MIDI thru box is an old Casio TB-1 that has 8 outs and still works great and I already had the “Pocket Merge” to use to merge the Pyramid and Controllers. DoReMidi also has a 3 in / 1 out MIDI merge box and a 1 in / 6 out MIDI thru box available if you need those units to put together a “Tuna Technique” routing system.

Here is a diagram of how I have it set up incase anyone is interested in doing the same. It’s technically the same as the previous diagram except it shows the use of the DoReMidi merge boxes.

1 Like


You may have MIDI loop problems with your setup unless you set;

-In the Pyramid, Settings → Midi Out → Midi Echo: set to STOP ECHO

You may want to add that to your programming section of your original post.

Check out the diagrams and explanation I just posted above regarding this “Tuna Technique” setup. Thanks!


all these flow charts give me tingles.

One thing that I think I’d be concerned about with a massive midi split to multiple synths then into a midi merge and then back into the pyramid (so the first post) is that I’d be worried about the midi thru features on the synths effectively duplicating all the midi channels, per synth.

Like, if any midi thru is enabled, it would pass through all the channels coming into it. If you split one midi signal and then have midi thru on multiple synths, each synth would effectively create a new duplicate stream of midi data for all channels.

So i think, you gotta make sure you turn the midi thru off on every synth that’s connected like that or insert a bomebox to filter per channel or something. Basically, you don’t want to create a bunch of feedback loops with midi thru settings so, I’d just make sure I’d double check that either the synth only supports midi thru on a dedicate hw midi port or that thru is disabled on a given midi out port.


I use the same approach as @rap4th, I just have “local off” enabled on all my keyboards (and pyramid midi modes set to MIDI Out), Which avoids the need for the “stop echo” setting, or the additional merge boxes. I was reluctant to do this initially, as it will introduce some latency (the midi events do a loop from the keyboard to the pyramid and back) but it doesn’t feel noticeable to me.
Obviously this approach also means I need to leave the Pyramid switched on all the time (and if i dont, i just need to toggle Local off on the keyboard), but so far it has worked perfectly.

Yes some synths have no dedicated MIDI thru output. And some synths let you select via a menu item to make the MIDI out to be a MIDI thru instead. Yes you need to make sure MIDI thru is turned off in these types of synths. That is usually the default setting in most synths anyways.

If your synth has dedicated MIDI out and thru outputs, then simply use the MIDI out port.

For me doing the “local off” trick is just a pain. Plus some of my synths don’t have this feature. They are always “local on”. Thus my solution solves this issue and pretty much makes any synth I introduce into the setup “Plug & Play”!! No possible latency and I don’t even need the Pyramid to be turned on if I just want to play the synths on their own.

It’s just a slightly different approach to achieving the same results without worrying about switching each synth to local off. And that’s why I decided to share it.


Thank you Jags!

I’m a new pyramid user and just set it up like this:

controller: arturia keystep midi out → kenton midi merger
midi out of prophet 6, moog matriarch, novation peak → kenton midi merger
the kenton midi merger out goes to the midi in of pyramid

midi out of pyramid to kenton midi merger, and the midi outs of this go to all the midi in ports of the synths.

So essentially the main difference with your setup is:

  • the keystep out does not go in to a separate merger first that merges the out of the pyramid and the keystep

but i don’t see why this should be a problem? if I only use 1 controller? please explain!
I do currently have some feedback loop problems: can i fix this with settings in the pyramid?
I want to be able to play the keyboard of the matriarch and p6, so local off is not really an option.

please help me understand why the extra (2) midi merge boxes are necessary!

It depends on if you plan to leave local control on in all your synths and have the “MIDI ECHO” set to STOP ECHO in the Pyramid. This is how I have it set in my setup. But if you have it set this way the MIDI out of the Keystep will not pass “thru” the Pyramid so that it plays any synths. That is why I have the additional mergers so that the Keystep goes both into the Pyramid and also to the synths.

Now the other way to do it, and how Mr.TUNA does it, is to turn off the “local control” in all your synths and then have “MIDI ECHO” set to ALLOW ECHO in the Pyramid. In this arrangement the MIDI out from the Keystep will pass “thru” the Pyramid to the synths but so will all the MIDI information coming out of all your synths. This will create a MIDI loop so that is why you have to have “local control” set to off on all your synths.

If you are OK with and are able to turn off “local control” in all your synths then it’s OK to do it the simpler way with just one merge box and one thru box. But doing it this way means you will always have to have the Pyramid powered up so that the MIDI signal can go out of the synth, thru the Pyramid, and back into the synth to play the sound. Remember “local control” will be off on your synths so playing the keyboard will not play the synth directly.

But you did mention that you want to be able to play the keyboard of the matriarch and p6, so local off is not really an option. In that case you will need the extra thru and merge box. The thru to split the signal coming out of the Keystep so you can send it both to the Pyramid and then back through the second merge box back to the synths along with the pyramid MIDI out.

It’s up to you on how you want your synths to behave. Controlled directly or controlled with MIDI first needing to pass “thru” the Pyramid.

To simplify things for you If you want to leave “local control” ON in your synths and to prevent any MIDI loops you will need to have the “MIDI ECHO” set to STOP ECHO in the Pyramid. But this will also prevent your Keystep from sending MIDI thru the Pyramid out to your synths. Adding the extra THRU and MERGE boxes solves this problem.

Another way to get around this problem is to go in and set the “MIDI ECHO” to ALLOW ECHO in the Pyramid every time you want to use the Keystep. This will allow the MIDI information from the Keystep to pass thru the Pyramid to your synths. A bit of a hassle but is doable and you wouldn’t need to purchase anything extra. But you will have to remember to go back and set the “MIDI ECHO” to STOP ECHO in the Pyramid everytime you want to start using your synths again.

Hope this helps!!

1 Like

thank you so much for this, I’m going to experiment!

Experimenting will be a good idea. It’s all about how you have the “MIDI ECHO” set in the Pyramid. You did mention that you already had some problems with MIDI loops and that is most likely because the “MIDI ECHO” was set to ALLOW ECHO in the Pyramid. The Pyramid is a very powerful tool and can be set up many different ways to best suite your workflow. It’s a great piece of gear!!

Good luck!

1 Like

Thank you Eric, and thanks for making that drawing specifically for my setup! very helpful!

I did however forget to mention that my setup is a bit more complicated even, as I use one of the midi outs (A) directly to my octatrack, which I use for sampling, but it also sequences my Vermona Pefourmer (I like the arp midi function of the octatrack).

However, I think this should not be a problem perse in this example?

Are you also sequencing your Octatrack and Pefourmer with the Pyramid or just sending midi clock? Why not just keep all of your gear on the MIDI A out of the Pyramid. I’m sure you don’t have more than 16 pieces of gear.

I just like to keep things simple and, unless I have some special need to have something specifically on it’s own MIDI output, I don’t think I’ll ever need the MIDI B out of the Pyramid.

Let me know how things are working for you once you get done experimenting with some of the different options we discussed.


will let you know, thanks!

So @Jags ; I just tried the following:

setup as I described firstly (so not with the extra merge/thru boxes yet).
I set the echo setting (midi in settings) to STOP ECHO
I have the keystep connected to the midi in on the pyramid (through a kenton merger)
and the midi out of pyramid goes to the novation peak (throug a kenton thru box first)

I am still able to control the peak with the keystep (in track and live mode on pyramid), with the STOP ECHO on. This surprises me, since if I understood correctly what you wrote above, this should not be the case?

Yes that surprises me also. Which MIDI out are you using from the Pyramid to your thru box?

Please also check this:

-In the Pyramid, Settings → Midi Out → Midi A Mode: set to MIDI Out (default)

Make sure this is set to MIDI Out (default) and not any of these other modes:

Let me know. Thanks!