Rample Confusion - help!

Hey all. I recently purchased the Rample, so forgive any dumb questions on my end. Anyway, my issue is this: the first day I got the Rample, it worked fine - samples triggered, I was able to switch banks, add effects - everything was dandy. But on the day immedietly after I was stuck on bank A0, and was unable to load other banks, though the encoder was displaying them.
I was confused, but I knew that there was a recent Rample update, so I removed the SD card to update it - now it’s saying that the card is “write protected” even though I have the adapter unlocked. So, I decided to try and put the card back in, but all I get is a red arrow. Upon holding down the encoder button, the arrow changes to a red line, and the module is otherwise unresponsive.
The module goes back to the red arrow immedietly upon switching my case off.
So, please help, I’m new to modular and this is incredibly discouraging and upsetting, especially since the module is brand new. Thank you!

sounds really strange…

if you cannot read the sdcard on your computer, Id hazard a guess that somehow the sdcard is corrupted - and if thats the case, Rample would have issues loading any kits.

(but Ive no idea, however, why the sdcard would work one day, and then not the next)

I think, unfortunately what your going to have to do is re-format the sdcard, and load the factory kits again - hopefully that should resolve your issues.

since the kits contained licence material, you will have to contact squarp via the contact form and they will be able to help you download them again.

that’s the weird thing, though! i’ve tried reformatting the SD, and no matter what position i put the adapter’s lock switch [locked, unlocked, halfway], even with a different SD adapter, it still says “Write protected.”

I’m at a complete loss. I live in the US, so sending it in for repairs to Squarp would be a big pain.

sounds like your adapter is broken.

micro sd cards do not have a write protect lock on them - its just a switch on your adapter, nothing to do with the micro sdcard itself