PyraOS 3.0: SEQ copy/paste weird behaviour?


#1

Hey folks. I’ve been working 10h a day with the Pyramid this week. So far, pretty good!

Now I’ve tried to rearrange my Sequences. Copy/Paste highlighting of the pads work. I can move the indicator light. But the sequences appear to stay where they were, only the lights change.

For example, I have a 5/4 rhythm on SEQ 02 and an empty sequence slot on SEQ10.

  • SEQ 02 is highlighted.
  • I copy/paste to empty SEQ 10.
  • SEQ 02 is now gray
  • SEQ 10 is now highlighted. All as I would expect.

But now: when I play SEQ10, I don’t hear the 5/4 stuff that was on SEQ02. It’s random other tracks. When I click the gray SEQ02, I can hear that the sequence is still there. Conclusion: only the light has moved, not the actual track selections.

I hope it’s not user error. Can anybody help?


#2

Hey!

It works for me.
2nd+COPY+PAD -> 2nd+PASTE+PAD

When you do this it shouldnt activate the destination sequence as you described.

Hope this helps! :wink:


#3

@joosep, thanks for chiming in. I’ve emailed squarp and they confirmed the bug. It will be fixed.


#4

Thats weird. I literally tried it myself. Probably just misunderstood…


#5

I don’t know, I didn’t have time to cross check, but I was sure I was getting the bug as described and Jean confirmed it. Glad they will fix it.

Luckily, I was able to work around it as I was preparing for a gig.
But thanks again for trying to help :slight_smile:


BUG in OS 3.0? - Pasting sequences