Pyramid not recieving aftertouch from Keystep


#1

I am trying to utilize the aftertouch that my Arturia Keystep creates to control my synths through the Pyramid. The keystep is plugged into the Midi In of the Pyramid, and I have made sure that the Keystep is correctly set up and that the Pyramid’s “Ignore Aftertouch” setting is set to off (though I have tried both ways just to make sure).

Still, the Pyramid does not seem to receive any of the keyboard’s aftertouch messages (there’s not any activity in the upper right corner of the Pyramid’s screen), and it does not pass the aftertouch on to whatever synth it is controlling like I’d want. It still receives all other messages from the keyboard just fine (e.g. notes and pitchbend).

Does this have something to do with “polyphonic aftertouch”, or the way that the Keystep transmits aftertouch? Is this something I can possibly fix? I’m very confused and frustrated about this, and would really appreciate some guidance. Thanks.


#2

pyramid only supports channel aftertouch … not polyphonic aftertouch.
(squarp should probably rename the option to Ch Pressure, to be clear and to be consistent with the step automation page)

channel aftertouch works fine for me, i.e. i can receive it, record it, and transmit it, with the keyboard have.
(i just had to change the midi in option for ignore aftertouch to off)


#3

I see… But, according to this article, the keystep has channel aftertouch, so I’m kind of confused. Maybe it got changed?

Thanks for the response.


#4

poly AT, i was just referring to second question… but yeah, poly AT is pretty uncommon.
(sorry dont have a keystep, and didnt check the specs)

what I would do is:

  • connect your keystep and pyramid to a computer,
  • record a quick sequence using your keystep with (channel) aftertouch into your daw.
  • check that you can see channel pressure in the automation
  • play that sequence to the pyramid from the daw.
  • look at the midi in data on the pyramid (settings info) , can you see the channel pressure data?
    (if its set to ignore AT, then it wont show in the midi in data, if its set to not ignore, then it will show)

if you cannot see the channel pressure in your daw, then you know the keystep is not sending it, its the setup of the keystep you need to look at.

if you see the channel pressure in the daw, then you know its the pyramid
(though as i mentioned, the only thing i did to make it work, is to ignore aftertouch to false)

a couple of other things, you could try:

  • draw the channel pressure into your daw, then play that to the pyramid.
    (also add a note, as ive seen some ‘software’ not send channel pressure if there is no active note… this is not ‘according’ to midi spec, but happens :wink: )
  • use a midi monitor on your pc/mac to look at the data coming from the keystep.

my suspicion, is its probably more likely to be a keystep thing that the pyramid…
Im assuming you have tried the keystep connected directly to the synth, and channel pressure works then??!?

note: im using the latest 2.3 pyraos, i dont know if this makes any difference, as only just got the pyramid, so not used any previous version of the OS.


#5

also, this is probably obvious, but what synths are you controlling? they do support aftertouch, right? i spent a little too long being frustrated at pyramid’s “accent” function before i realized the synths i was testing didnt have velocity support.


#6

Just hit this wall tonight. :frowning:
Has there been any indication from Squarp that Poly Aftertouch may come in future?


#7

Isnt that a heinous amount of data?